0

Yesterday I lost my internet connection after rebooting my Ubuntu 16.04 installation. Now when Ubuntu boots, it searches for a network for a couple of minutes, then states "Connection established" but I can't get online or communicate (send ping requests, for instance) to anyone.

I deleted the ethernet network, hoping it would re-initialize if I re-added it. When I click the network manager icon, the "Ethernet Network" is greyed out (so I can't enable it). There is a new entry now, called "Auto Ethernet" but that one doesn't work (same symptoms as I mentioned earlier).

If I try to add a new ethernet network connection, the "eth0" is gone from the list of devices. Instead, I now have a "eno1" entry which I've never seen before. It might be the same device that is renamed but I don't know.

My /etc/network/interfaces file contains

auto lo
iface lo inet loopback

Is there some way of re-installing my network manager and/or ethernet driver without network connection? Or am going to have to reinstall Ubuntu?

  • Your network interface was named differently because, as of 16.04, interface names adhere to a standard called "Predictable Network Interface Names" described here. However, your /etc/network/interfaces ought to contain a line auto eno1 followed by either a dhcp line or a description of a static IP address. – Jos May 13 '16 at 7:31
  • Added "eno1" entry to /etc/network/interfaces: auto eno1 iface eno1 inet dhcp. Still, same error – gromit190 May 13 '16 at 7:34
  • Did you sudo systemctl restart networking? – Jos May 13 '16 at 7:34
  • Tried that now, it seemed to just hang forever. Rebooted a couple of times. Tried "sudo ifdown eno1" just to try to re-enable the device or whatever. It hung at "waiting for lock" for a while. Rebooted some more. Suddenly, my connection works again. – gromit190 May 13 '16 at 7:48
  • I tried to remove the eno1 entry in /etc/network/interfaces, rebooted and it is now working. However, the entries in my network manager dropdown are "Ethernet Network"(greyed out), "Auto Ethernet"(enabled). Is ther "Ethernet Network" broken, and replaced by "Auto Ethernet"? Why are there two entries there when I only have one (the "Auto Ethernet") in my network manager window? – gromit190 May 13 '16 at 7:50
1

This answer summarizes the chat:

You can either:

  • let NetworkManager take care of network connections; make sure that managed=true in /etc/NetworkManager/NetworkManager.conf. Restart the Network Manager after changes: sudo systemctl restart NetworkManager. Obsolete entries in /etc/NetworkManager/system-connections can be deleted; if necessary, they will be recreated.

  • do away with NetworkManager altogether, as described here. In this case, the file /etc/networking/interfaces is decisive.

The fact that your network interface was renamed has to do with systemd adhering to a standard called "Predictable Network Interface Names" described here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.