When I started my laptop, there was no network service, and also no network icon in the top bar. It gives an error when I start OS like "Sorry, Ubuntu 14.04 experienced an internal error". When I click details, it says the error is occurred in the executable path usr/sbin/NetworkManager. Also, when I try to enter Network in the System Settings, it says "the system network services are not compatible with this version"

How can I solve this shocking issue?

p.s. I didn't install any third party packages/apps related with networking. Only system updates are installed.

up vote 26 down vote accepted

I got the same problem today.

TLDR: downgrade libnl3 or upgrade network-manager.

As per this answer, problem is that a fix in libnl3 caused a regression in network-manager. Then, it was only a bug for -proposed packages, but I guess bug was tested enough that it could be introduced into regular Ubuntu ;).

Safest way is to take a step back and install earlier versions of libnl-3-200 libnl-genl-3-200 libnl-route-3-200 (see details in said answer).

This leaves you with downgraded packages. Remember to not upgrade them until relevant upgrade for network-manager is available.

Alternatively (I did this), you can take a step ahead and install newer version of network-manager: for amd64 or for i386. You can download package on different system and pass it with USB stick. Or download it with your smartphone and pass it via USB.

Install it with:

sudo dpkg -i network-manager_*.deb

You can try to get networking by just restarting NetworkManager:

sudo service network-manager restart

But I needed to reboot to get systray applet back.

  • so, do we (14.04) need to avoid network manager updates now? – MInner May 14 '16 at 5:13
  • 1
    My system is not getting connected to ethernet... So how will i update the network manager? Moreover the command line that u gave for updating network manager is not working – Richa Tibrewal May 14 '16 at 5:36
  • @RichaTibrewal Download them on other OS/PC and pass via USB stick. That's what I did. I fixed the typo in the command as well. – tamkderplar May 14 '16 at 9:39
  • 1
    It's also instructive to mention that the trusty-proposed updates should be turned off so as not to allow the version incompatibility that causes this in the first place, as detailed on the page that @tamkderplar linked to. – UserName May 14 '16 at 10:29
  • @UserName i never had trusty-proposed turned on, but got affected by regular updates yesterday. – samy May 14 '16 at 10:59

This method works if you can connect by Ethernet cable.

Use Ubuntu's built in recovery mode to upgrade Network Manager.

Step 1

Use the down-arrow key to select Advanced options for Ubuntu and press Enter

Step 2

Use down-arrow key to select the latest Linux kernel with Recovery Mode and press Enter

I used Ubuntu, with Linux 4.2.0-36-generic (recovery mode)

Step3

Use down-arrow key to select network Enable Networking and press Enter

Step 4

Press Enter for OK to remount the file system

Step 1 to 4 screenshots

Step 5

Use the down-arrow key to select dpkg Repair Broken packages and press Enter

Step 6

It will ask to download the latest Network Manager with Continue [Y/n]. Input letter y for "yes" and press Enter. When all operations have finished it will say

Finished. Please press Enter

So press Enter again.

Step 7

Select resume Resume normal boot and press Enter

Step 8

Press Enter and continue to boot. At the login screen DO NOT log in instead do a NORMAL restart (click shutdown icon at the top right area of the screen).

After the PC restarts then log in.

Network connections were back when I did these steps.

Step 5 to 8 screenshots

  • 1
    This only works with an ethernet connection. – Alex Edwards May 14 '16 at 0:04
  • 1
    Thanks! This worked!! It's too much of a surprise to get your OS lose network after update. – ShitalShah May 14 '16 at 1:05
  • When i select network enable networking... I get modemmanager is shut down – Richa Tibrewal May 14 '16 at 5:33
  • I also got a "Modem Manager is shut down" and the system was stuck to that. I then connected my ethernet cable and it started to work again after a few seconds. – alexandru.topliceanu May 14 '16 at 8:17
  • @RichaTibrewal I suggest you follow the steps suggested in this link – UserName May 14 '16 at 10:25

You can do it this way to fix the problem:

Download file:

  • libnl-3-200_3.2.21-1_XXX.deb
  • libnl-route-3-200_3.2.21-1_XXX.deb
  • libnl-genl-3-200_3.2.21-1_XXX.deb

    OS 32bit: XXX = i386 || OS 64bit: XXX = amd64

Link: http://archive.ubuntu.com/ubuntu/pool/main/libn/libnl3/

To them into one folder and install them with the command:

sudo dpkg -i lib*.deb

Then Reboot. Done :3

  • does not work for me – ji-ruh Jul 10 '17 at 4:27

I would not recommend downgrading packages or installing new ones by hand - this will inevitably lead to version issues later on. The best fix to this issue is simply to upgrade the network-manager package.

The first thing to do is to connect manually to the internet; while the network-manager is dead this does not mean you can not connect.

1. Open a terminal and edit the interfaces file:

sudo pico /etc/network/interfaces

There add the following lines, they indicate the eth0 interface should no longer be managed:

allow-hotplug eth0
iface eth0 inet dhcp

2. With this the connection can be started manually:

sudo ifup eth0

Note that there will be no notification in the panel - this is a manual connection. Give it a try with ping or firing up your internet browser.

3. Now update the apt meta-data:

sudo apt-get update

And upgrade the network-manager package:

sudo apt-get upgrade network-manager

4. Make sure you now have version 0.9.8.8-0ubuntu7.3 installed:

apt-cache show network-manager

5. Now edit again the interfaces file and remove or comment the lines added in step 1.:

sudo pico /etc/network/interfaces

6. Finally reboot the system.

protected by Community May 14 '16 at 4:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.