3

On 12.04 I used to utilize this procedure, to power off my ATI graphics and prevent my system from overheating, it worked fine. After installing 16.04, I've been trying everything I could find on the net, but no solution. My system runs extremely hot, causing the fans to run at max almost all the time. Can anybody come up with a little hack to shutdown that discrete ATI Radeon card?

thanks. M.Schoofs

System: HP Pavilion dv7-6190ed (FW F.18) [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]

6

Check graphic drivers which are in use (radeon/amdgpu should be listed):

lspci -nnk | grep -i vga -A3 | grep 'in use'

Note: If amdgpu is listed, replace radeon with amdgpu in the instructions below!


Open the following file:

gksudo gedit /etc/default/grub

Modify the following line by adding radeon.modeset=0:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

Save and Exit


Back to Terminal:

sudo update-grub
sudo reboot

Check again which graphic drivers are in use (radeon/amdgpu should not be listed anymore):

lspci -nnk | grep -i vga -A3 | grep 'in use'

Now, your ATI/AMD graphic card is disabled and your computer works only with the Intel graphics. The fan speed should significantly decrease.

  • What if the driver in use is Intel onboard (i915) instead of ATI's discreet, but the fan still runs and heats up. Could I still apply the same change to grub? Would it work? It started happening when I upgraded kernel build to 4.4.0.22 from 4.4.0.21 (battery life reduced). – Mookey May 20 '16 at 8:00
  • check if your discrete card is powered: sudo cat /sys/kernel/debug/vgaswitcheroo/switch... since the kernel update it is powered without beeing in use... if so, then do the above instructions, so far the only thing that works for me... – Neni May 20 '16 at 8:05
  • 4.4.0.21: 0:IGD:+:Pwr:0000:00:02.0 1:DIS: :DynOff:0000:04:00.0; 4.4.0.22: 0:IGD:+:Pwr:0000:00:02.0 1:DIS: :Pwr:0000:04:00.0 – Mookey May 20 '16 at 8:21
  • So both kernels are the same, yet there's a considerable difference. – Mookey May 20 '16 at 8:22
  • That's the point, your DIS(crete) graphics card is powered by default... the dynamic power management is not working properly since the kernel update... powering off the discrete card (echo OFF > /sys/kernel/debug/vgaswitcheroo/switch) is causing problems on reboot... we just have to wait until the end of summer 2016, then the new proprietary driver for amd/ati should solve all the problems... until then, disable your ati graphics as described above... I have no other solution... – Neni May 20 '16 at 8:28
4

Following Neni's answer, I had kernel panic after sleep. I solved my problem by adding radeon.modeset=0 amdgpu.runpm=0 acpi_backlight=intel_backlight to GRUB_CMDLINE_LINUX_DEFAULT

To edit file :

sudo nano /etc/default/grub

Find line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And replace with :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0 amdgpu.runpm=0 acpi_backlight=intel_backlight"

To regenerate config :

sudo update-grub

Reboot :

sudo reboot


What those options do :

  • radeon.modeset=0 disables radeon driver
  • amdgpu.runpm=0 disables the power management from amdgpu driver
  • acpi_backlight=intel_backlight uses intel driver to control laptop screen backlight

Official bug report suggests as a workaround either manually install newer kernel (which you would have to manually update) or run those steps :

  1. /etc/default/grub: Add amdgpu.runpm=0 to GRUB_CMDLINE_LINUX_DEFAULT
    Included above.

  2. /etc/rc.local: Add the following command:

    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    This step caused my system to freeze on shutdown so I just skipped it.

  3. /etc/X11/xorg.conf: Create the file if it doesn't exist, and add the following in order to get the backlight controls working (otherwise it would be misdetected):

    Section "Device"
        Identifier "Card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
    EndSection
    
    This step is replaced replaced above by acpi_backlight=intel_backlight

  • What AMD chips do you have? My iGPU is in a Richland APU, the dGPU is 7970m (GCN1.0), so I can't use the new AMD drivers. But I'll give it a shot. – ecth Mar 9 '17 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.