4

I'm looking at my syslog and seeing very little in the way of useful information about this, but whenever I try to connect to a wifi or VPN connection, I don't get any prompt for auth but the menu on Gnome says "waiting for authentication". I'm not sure how to go about fixing this? It seems to have started happening only since I upgraded to 16.04, and I'm using vpnc (Cisco VPN) on top of the Network-Manager thing.

The syslog just contains info like the UI, e.g it shows the states going from waiting for authorisation to disconnected, it doesn't say anything about trying to prompt for auth.

So far I've tried:

  • Re-installing the network-manager
  • Restarting dbus
  • Multiple reboots
  • Cleaning out the folder with all the network configurations in and starting "from scratch"

These steps were taken from the answers in: Unable to connect to VPN using gnome-network-manager

Which this may be a duplicate of? I'll let this exist for now as the solutions there didn't help me and I'm not sure the root cause is the same.

It happens for WiFi, VPN, and any other type of connection which requires auth and uses the network-manager application.

kern.log contains:

May 16 10:11:58 joshuagdev NetworkManager[820]: <error> [1463389918.6751] vpn-connection[0x18b7400,c69258b7-65c1-41d2-86a0-7270b1d4e2a7,"Cambridge VPN",0]: Failed to request VPN secrets #3: No agents were available for this request.

I'm not sure exactly what this means, but it looks like it could be the root cause.

Update. I've managed to connect to the VPN using a terminal:

root@host:/home/user# vpnc-connect
Enter IPSec gateway address: hostname
Enter IPSec ID for hostname: groupuser
Enter IPSec secret for groupuser@hostname: secret
Enter username for hostname: user
Enter password for user@hostname: rsapassword
VPNC started in background (pid: 10735)...

While this solves the problem that I can't get on the VPN, it doesn't solve the problem that I now have to do it the hard way. More suggestions are always welcome!

  • In the mean time you can enter the password in the Settings > Networks (in Unity, but should be the same in Gnome). – jena May 16 '16 at 9:18
  • Sadly in the time it takes me to enter the password it's normally reset itself (RSA auth). I did try something similar a few days ago where I did exactly this, only in the network-manager configuration file directly - this did not let me in (auth failure), but presumably it at least tried the password and it had simply expired. – XtrmJosh May 16 '16 at 9:19
  • @jan would you agree this is a dupe? The logging looks the same (askubuntu.com/questions/515982/…). I can't flag it for the bounty though. – XtrmJosh May 16 '16 at 9:22
  • log might be the same but the issue seems different so I would keep it separate (especially if the solutions there didn't help you). – jena May 16 '16 at 9:24
  • BTW I also use vpnc and it works only when I install network-manager-vpnc-gnome and not with just network-manager-vpnc. But this will probably not solve all your problems (if any). – jena May 16 '16 at 9:26
1

You have not got gnome-keyring installed.

Correct this with

sudo apt-get install gnome-keyring

sudo apt-get update
  • Alas, no luck. I don't suppose there might be a scenario where gnome keyring might be at the wrong version? For some reason when I open the "passwords" app (it's called passwords and something, but I can't remember what as I'm temporarily using Plasma), it says "gnome2-keyring" on the left, implying that while the DE itself is on gnome3, the keyring is on gnome2... Has keyring been replaced or made redundant in some way by the latest Gnome DE update? – XtrmJosh May 23 '16 at 14:08
  • Try tidying your repository with sudo apt-get update sudo apt-get autoremove sudo apt-get install -f paste the entire termional dialog into your question. You can use paste.ubuntu.com – Steve Roome May 23 '16 at 14:58
  • @XtrmJosh did you try my suggestion? – Steve Roome May 25 '16 at 19:25
  • Not yet, sorry, we're having a busy period and I'm having to make do with KDE for now. I should get around to it Friday! – XtrmJosh May 25 '16 at 20:40
  • Thanks, this helped me. (On ArchLinux though.) I wonder why this happens in the first place. Not prompting for password and silently failing is so unbelievably wrong.. – VasyaNovikov May 3 '18 at 9:53
-1

Found this on other help sites. Not sure if it will help. You could give it a try though.

Create a new file /etc/modprobe.d/ath9k.conf Type in Terminal sudo nano /etc/modprobe.d/ath9k.conf Add the following line to it: options ath9k nohwcrypt=1

Save the file and reboot. Good luck!

  • ath9k looks to be a very specific driver for a wifi adapter - it's not on this machine and I suspect installing it would cause some catastrophic conflict and destroy my wifi adapter entirely. Thanks for the thought though! – XtrmJosh May 20 '16 at 12:29
  • No, it's just a .conf file, which is used to configure settings, such as user settings or server processes. My guess is this one is linked to the default wifi adapter. Anyway, I respect not destroying your computer ;D – James May 20 '16 at 16:17
  • don't edit your wifi config to disable hardware encryption , thats a completely daft idea and nothing to do with VPN's. Completey different layers of the networking stack. @James you should delete that comment its going to cause people lots of problems – Amias May 22 '16 at 10:39
  • ath9k is actually an open source wifi adapter driver - not just a config file. The file you're speaking of is in fact a config file for ath9k (hence the naming), and the driver is not installed on my machine. Installing it could cause all sorts of issues which I don't want to have to solve. As I said, thanks for the effort :) – XtrmJosh May 22 '16 at 13:11
  • Alright. This worked for me a while back. I wish you the best of luck! – James May 22 '16 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.