2

I've installed Ubuntu 16.04 LTS along side with Windows 10 (I shrinked my Disk using Windows Disk Management) on my Acer laptop (ES1-531-C13G), but when I restart/reboot my system no menu (Grub screen) appears from where I can select the operating system that I want to boot with, but instead, system takes me into Windows 10 everytime. I've tried several things from internet including :

  • Ran bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi from windows command prompt.
  • Reset Bootorder i.e. first Ubuntu then Windows from Ubuntu terminal (after successful Ubuntu installation) etc, but nothing works for me so far. Please guide me !
6

@oldfred thanks very much for your support, links you shared really help me out. Following are the steps of the solution that works for me.

Press F2 to enter into BIOS and do following:

  • Set supervisor password from Security menu option.

  • Set BootMode to 'UEFI' from Boot menu option.

  • Enable SecureBoot from Boot menu option.

  • From Security menu option - Select 'UEFI file as trusted for
    executing' press Enter then 'HDD0' appears press Enter then 'EFI'
    appears press Enter then select 'ubuntu' option from the list (only
    listed if you have ubuntu installed already) press Enter then choose 'shimx64.efi' (In my case it's the third entry) press Enter give it a name and press Enter.

  • Go back to Boot menu option and under Boot priority goto
    'ubuntu' item in the list and press F6 until it become top most item in the list. Repeat same for 'Windows Boot manager' until it becomes second top most item in the list.

  • Press F10 to save changes and exit.

  • I just followed all of your steps and it worked. A couple things though. My computer was already set to UEFI boot and SecureBoot, so no change there. Also, the ubuntu item would not show up after doing the "UEFI file as trusted" step, but it did after rebooting once. If the ubuntu item is not set to be the first option it won't boot into Ubuntu, so in my case a reboot and making it the #1 option was necessary. Thanks a lot. – Juanpi Jan 27 '17 at 12:22
0

someone posted this:

The trick was to manually copy the ubuntu Boot directory in place of the \EFI\Boot Directory, and rename shimx64.efi to \EFI\Boot\bootx64.efi (not \EFI\Microsoft\Boot\bootmgfw.efi )

Boot-Repairs fix is the rename of bootmgfw.efi, which has to be redone if Windows updates its files. And then can only boot Windows from grub menu.

Some other options:

Alternative to Boot-Repairs rename of shim. Some systems work better to register grub/shim from inside Windows - for those that keep resetting Windows as default

Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

https://coderwall.com/p/vfyqkg

Some install rEFInd which seems to be another workaround.

http://www.rodsbooks.com/refind/index.html

http://www.rodsbooks.com/refind/secureboot.html

  • 1
    Acer has some unique UEFI requirements. It requires you to set an UEFI password and enable "trust" on the ubuntu/grub efi boot files in the ESP - efi system partition. Acer Aspire ES1-512-C39M Details on supervisor password and settings to enable trust on ubuntu entries Also R14 model same fix One of several with more details: ubuntuforums.org/showthread.php?t=2297947 and: ubuntuforums.org/… You may also find threads, suggesting down grade Acer UEFI, but newer threads, say newest UEFI from Acer works. Make sure you have newest. – oldfred May 12 '16 at 19:09
  • Thanks for the replies. @oldfred I don't have mush experience with BIOS therefore most of the things that you said just flew over my head :) keeping it simple I have some questions 1. From BIOS, If I changes the default boot option from UEFI to Legacy does it solves the problem and can I then able to see the Grub screen (from where I can select any OS)? 2. I just noticed that in BIOS Boot menu under boot priority there isn't any ubuntu option listed - does that means that ubuntu not installed properly? – Umar May 12 '16 at 22:22
  • During ubuntu installation I remember there was an option i.e. 'Turn off secure boot' which I didn't check is this something relevant to UEFI password and enable "trust" thing? Also, if I follow the instructions do I have to reinstall ubuntu ? – Umar May 12 '16 at 22:27
  • Secure boot is just an UEFI option. Users can turn that on or off and still boot in UEFI boot mode. BIOS or CSM is only Secure boot off. You may have set password to change the UEFI Secure boot setting. And many systems do not even mention UEFI Secure boot, but just call it "Windows" and "Other", but if installing Windows 7 you have to use "Other", since 7 is not able to boot with Secure boot on. – oldfred May 12 '16 at 23:44

protected by Community Sep 21 '17 at 16:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.