0

I updated my home ubuntu server with a lot of updates (I think it was quite 1 year I didn't update anything).

After this Transmission setting file /var/lib/transmission-daemon/info/settings.json disappeared. I wrote it again, Transmission starts but after a while it stops with this error:

errr Unable to save resume file Permission denied

I gave permission 755 at the following folder and sub:

  • /var/lib/transmission-daemon/info
  • /var/lib/transmission-daemon/download
  • /media/virtual/downloads ("download-dir")

This is what I get with strace:

sandro@naSan:~$ strace -f -e open transmission-daemon
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/libminiupnpc.so.8", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/librt.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libcurl-gnutls.so.4", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libcrypto.so.1.0.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libz.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libpthread.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libidn.so.11", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/librtmp.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libgcrypt.so.11", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libgnutls.so.26", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/liblber-2.4.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libdl.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libgpg-error.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libtasn1.so.6", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libp11-kit.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libkrb5.so.3", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libk5crypto.so.3", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libcom_err.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libkrb5support.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libresolv.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libsasl2.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libgssapi.so.3", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libffi.so.6", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libkeyutils.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libheimntlm.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libkrb5.so.26", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libasn1.so.8", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libhcrypto.so.4", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libroken.so.18", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libwind.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libheimbase.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libhx509.so.5", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/x86_64-linux-gnu/libsqlite3.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib/x86_64-linux-gnu/libcrypt.so.1", O_RDONLY|O_CLOEXEC) = 3
Process 3138 attached
[pid  3138] open("/dev/null", O_RDWR)   = 3
[pid  3137] +++ exited with 0 +++
Process 3139 attached
Process 3140 attached
[pid  3140] open(0x7efd059823c0, O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or dire                        ctory)
[pid  3140] open(0x7efd059823f8, O_RDONLY|O_CLOEXEC) = 13
[pid  3140] open(0x7efd059823cd, O_RDONLY|O_CLOEXEC) = 13
[pid  3140] open(0x7efd059823cd, O_RDONLY|O_CLOEXEC) = 13
[pid  3140] open(0x7efcf8000f00, O_RDONLY|O_CLOEXEC) = 13
[pid  3140] open(0x7efd059843cc, O_RDONLY|O_CLOEXEC) = 13
[pid  3140] open(0x7efd0547b435, O_RDONLY|O_NOCTTY|O_NONBLOCK) = 15
[pid  3140] open(0x4611f8, O_RDONLY|O_CLOEXEC) = 15
[pid  3140] open(0x4611f8, O_RDONLY|O_CLOEXEC) = 15
[pid  3140] open(0x4611f8, O_RDONLY|O_CLOEXEC) = 15
[pid  3140] open(0x4611f8, O_RDONLY|O_CLOEXEC) = 15
[pid  3140] open(0x4611f8, O_RDONLY|O_CLOEXEC) = 15
Process 3141 attached
[pid  3138] open(0x1a15420, O_RDWR|O_CREAT|O_EXCL, 0600) = 19
[pid  3138] open(0x7efd04c91ab0, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcf00008c0, O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or dire                        ctory)
[pid  3140] open(0x46485e, O_RDONLY)    = 20
[pid  3138] open(0x7efd04c911f0, O_RDONLY|O_CLOEXEC) = 21
[pid  3141] open(0x7efd04c92a91, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd04c92bcd, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd05fc0e47, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd061bfe62, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd04c92ad8, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd05fc0e47, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd061bff0c, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd04c92a91, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efd04c91625, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] open(0x7efcfee06fc1, O_RDONLY|O_CLOEXEC) = 20
[pid  3141] +++ exited with 0 +++

Now I get this error from the web interface:

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

File "settings.json" and "stats.json" have lost 775 and are now 600.

  • you could try running it via strace and filter the output to just open calls to see which files its opening or failing to open. strace -f -e open transmission if you don't have strace installed you can install it by doing apt-get install strace – Amias May 12 '16 at 18:36
  • I solved the problem: see my answer below – Sandro May 12 '16 at 22:05
  • How are you running Transmission? As a system daemon or as a user daemon? – David Foerster May 12 '16 at 22:08
  • Sorry, David. I don't know – Sandro May 12 '16 at 22:14
  • How do you start Transmission? Do you start it from a (possibly graphical) user session or with the system service manager (service, initctl, systemd depending on the init system of your Ubuntu release)? Or is it started automatically on system start or user log-in? – David Foerster May 12 '16 at 22:20
1

I solved this way:

1) Uninstall Transmission. All of it. Every package.

sudo apt-get autoremove transmission-common

2) Delete every transmission* package in /var/cache/apt/archives

sudo rm /var/cache/apt/archives/transmission*

3) Check if your package manager is working properly

sudo apt-get upgrade && sudo apt-get update

4) Install Transmission again

sudo add-apt-repository ppa:transmissionbt/ppa

sudo apt-get update

sudo apt-get install transmission-cli transmission-common transmission-daemon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.