0

In Gnome 3, the Terminal/monospace font rendering is really bad - not smooth, but thin and jagged.

What can I do to make it smooth, somewhat "blurry"? It doesn't seem to follow Gnome Tweak Tool's configuration.

1

Fixed by setting Hinting to Slight in Gnome Tweak Tool.

1

Expanding on the accepted answer which some may need extra pointers with...

System-wide font smoothing (anti-aisling)

This really isn't a gnome-terminal problem but a system-wide problem. The easiest way I know to solve it is with the Tweak Tool. In my case I'm using unity-tweak-tool. Install it with:

sudo apt install unity-tweak-tool

Usage

Start it from Dash or the command line using unity-tweak-tool.

Click on the icon "Fonts" and notice this part of the screen:

Unity tweak tool Fonts.png

The Text scaling factor is only increased for HDPI (High Dots-Per-Inch) monitors such as 1920x1080. The other two fields are the ones that worked best for me to smooth out fonts.


Available tweak tools

To list available tools for your Ubuntu version use:

$ apt-cache search tweak-tool
gnome-shell-extension-autohidetopbar - GNOME shell automatic topbar hider
gnome-shell-extension-suspend-button - Gnome-shell extension to modify the suspend/shutdown buttons
gnome-shell-extensions-gpaste - GPaste extension for GNOME Shell
gnome-tweak-tool - tool to adjust advanced configuration settings for GNOME
unity-tweak-tool - configuration tool for the Unity desktop environment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.