1

This is a bit of an odd problem, but after upgrading to Xenial, something went wrong with my sound quality, which was working beautifully under 15.10.

After the upgrade, there is a strong distortion that sounds as if I had blown speakers (I don't). This is true for system sounds or any audio/video files I play. Even with the volume at 50%, it's still a problem.

I have no idea where to begin as this has never happened before. It applies across distros/DEs as it affects Ubuntu MATE and Kubuntu as well as my main Unity installation. I've tried fiddling with the sound settings, ALSA Mixer, and the Pulseaudio EQ, but other than that, I have no idea how to troubleshoot the sound card.

Edit: As requested, I've added additional information.

My PC is a Lenovo Y480

My soundcard is:

Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

The output of sudo aplay -l is:

**** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 1: ALC269VC Digital [ALC269VC Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0

  • You said it applies across distros. Just Ubuntu or Debian-based ones? Did you try others like Fedora/Arch/Suse… too? The sound tag wiki has instructions for troubleshooting sound issues and required information that is needed for further investigation and filing bug reports or asking on the respective mailing lists (Alsa or PA): askubuntu.com/tags/sound/info – LiveWireBT May 19 '16 at 1:33
  • Sorry that was poorly worded. I should've said DEs, but I used the word distro because the Ubuntu flavors are released as seperate distros. To be clear, I meant Ubuntu DEs only. My installation is the Unity version, but I also have MATE, GNOME, and Cinnamon installed with it. – Giambattista Jul 19 '16 at 20:30
2
+50

A change to your alsa-base.conf in /etc/modprobe.d/ may be needed but it is not possible to say for certain as you have not listed what make and model your computer is (there are sometimes specific changes for specific hardware required in /etc/modprobe.d/alsa-base.conf and your device may not have the correct device selected even if it is not a device requiring special changes in alsa-base.conf). For example, we need to output of sudo aplay -l and lspci -v | grep -A7 -i "audio" should show exactly your sound card, or you need to make changes and perhaps add some packages. Please list your device and the output of the sudo aplay -l command so that we can be more helpful.

This should also be useful to you: https://help.ubuntu.com/community/SoundTroubleshooting

Respectfully, David

| improve this answer | |
  • Comments are not for extended discussion; this conversation has been moved to chat. – terdon Jul 24 '16 at 13:20
0

I came across your question just now as I had exactly the same issue. I found the answer in this question solved the issue for me.

In my screen I had to ensure "Allow louder than 100%" was checked before the "unamplified" setting was visible.

enter image description here

| improve this answer | |
  • Thanks for your answer. Unfortunately, the solution did not work for me. I was working in MATE a minute ago, and the sound settings are completely different, so I logged into Unity and I'm still not seeing anything about unamplified in either MATE or Unity even when the allow volume > 100% is checked. – Giambattista Jul 19 '16 at 20:46
  • Just looked at my sound settings and it looks like it has changed since I wrote that. When "Allow louder than 100%" is checked, it now shows the 100% position on the output volume slider (this used to be titled "unamplified" last time I looked). I find that when the slider was equal or less than this position, it solved the problem. I've added a screenshot above to clarify. – gsxruk Jul 25 '16 at 18:31
  • Thanks for the clarification, but that's still not my problem. It occurs when the volume is below 100% – Giambattista Jul 25 '16 at 19:14
0

For me the solution was to reduce the outgoing sound, then the " strong distortion that sounds as if I had blown speakers" disappeared. You find it in the "Sound settings" and the tab "Applications". I'm using VLC.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.