I have an intel NUC 5i7RYH, my BIOS is RYBDWi35.86A.0355.2016.0224.1501.

That system ran flawlessly under 15.10. I recently upgraded to 16.04 LTS on April 23rd. The unit was bricked the next morning, and the NUC has now bricked four times in total, twice the last four days. My power setting is "Don't Suspend" -- it's set there to avoid inviting the situation where the unit becomes unresponsive and will not wake up (not just to mouse and keyboard inputs, it won't even respond to the power button). When bricked, the unit has to be disassembled, the CMOS battery disengaged, then put together again. Such a fun way to start the morning. Every occurrence happens the same way. I stop my work and leave the system running overnight. When I return to my desk in the morning I hit the keyboard and mouse and there is no reaction. Than I hit the power button -- now cringing because I know there is about a chance that there will be no response when I do so.

I am using a wireless Logitech mouse and Keyboard. My Advanced Power BIOS settings are as advised by Intel:

Wake from S3 via CIR Wake from S4 and S5 via CIR USB S4/S5 power

I wonder if I need to resort to a crappy USB mouse/keyboard setup rather than wireless.

Windows users do not seem to be plagued with this issue. Or at least they can recover from it using the "Wake on LAN" feature to start an unresponsive unit from a mobile app. That doesn't work for me. The 16.04 settings for Ubuntu allow me to set that feature for the wired ethernet connection but the wifi connection -- which is what I am using -- does not expose that option. Setting the wired option and using the wifi does not work.

The unit will accept a remote control, and that also works for Windows users. I can steal a remote from my TV if required, but when I searched for the "directions" to add a remote to a NUC running Ubuntu too many of the posts starting out saying, "After two days of trying everything . . ."

These NUCs are great little machines when they run, but it absolutely sucks that Intel hasn't been able to fix this long-standing problem. They have advised me to post the issue over here.

  • +1 Very nice, high quality post. Although I may advise you to shorten it if possible. May 21, 2016 at 12:24

3 Answers 3


I have had a nearly similar problem with NUC's specifically with wireless K/B combo's.

Use an USB extension cable for the K/B & Mouse Wireless receiver. I have had 2 separate situations where the inputs from the K/B & mouse were freezing the NUC, and had to reboot via power button - admittedly running W10 though..To test my theory I used a wired Keyboard and mouse..the problem disappeared for me.

If you search on the Intel forums it's a known problem with interference with the wireless network card AND USB wireless receivers (input) for wireless K/B & mouse - like that Logitech. It's all because of everything jammed in that tiny NUC case and the interference it causes.

  • The USB extension is already in use. Yes this is a well-known issue in the Intel forums. Note in my post that they asked me to post it here.
    – eezis
    May 29, 2016 at 13:53

I have encountered this problem when I upgraded Mythbuntu from 15.10 to 16.04 with the XFCE graphical user interface(GUI). At first I thought it was the screen saver (xscreensaver) that comes with XFCE. Finding that disabled, I checked the HDTV that is being used as a screen and searched its options. Nothing there. I noted that in the latest Mythbuntu, in the front-end setup configuration, the default setting for it to go into suspend when there is no activity is 16 minutes. Setting it to 0 stops it going into suspend. I set it 0 and it stopped going into suspend and all was right until I turned off the TV. When I turned the TV on again, the screensaver, which is part of the TV, nothing to do with Mythbuntu, was showing. Tapping the keyboard,moving the mouse pointer using the touch pad, nor disconnecting and reconnecting the HDMI, causes the screen to come back to life. Pushing the on/off button causes the computer to shut down. On restarting, the HDMI is once again activated and the screen comes back to life until you turn off its power and then, immediately afterwards, turn it back on; only to be greeted by the TV's screen saver.

I have done a totally fresh install of Mythbuntu 16.04, formatting all partitions beforehand, and the problem, as expected, is still there.

In other words, the problem would seem to be with the operating system, 16.04 and, guessing, is most probably driver related when using HDMI. I haven't had the time yet to try other video outputs.

I can definitely say that the moment, if you turn off the power to the monitor and when you turn on the monitor again, even immediately after having turned it off, the HDMI active is not detected by the computer.

A confusing problem but I think, at least, I have positively identified what is causing it. I hope this is helpful to the Ubuntu developers. The mother board is a Gigabyte ITX using an Intel i5 processor.


Intel now has a BIOS update fix for this that you can get from their Intel Download Center. This issue also affects 6th gen (Skylake) NUCs and a BIOS fix is forthcoming for those.

  • Do you have a link/URL you can reference? That would help this answer tremendously.
    – gravity
    Jul 6, 2016 at 2:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .