3

My question appears to be very similar to the following mostly unanswered question.

I have an Autopilot installation (I followed these instructions) with one MaaS master, one Landscape Autopilot server, and 5 floating machine. One of these five floating machines is configured during the install to host the networking node.

~90% through the installation it stalls because it is waiting for juju to deploy into LXC on the to-be-networking node. However, this never completes. It can wait for days.

I am not able to ssh into the to-be-networking node from the MaaS master. However, it reports being correctly deployed. Indeed I can and have watched it deploy and watched the MaaS master NAT its traffic successfully.

During the Autopilot installation of OpenStack, other nodes also have juju deployed under LXC. All of these succeed. The only holdout is the networking machine.

2
  • You are using the vmware appliance trial? or you have physical machines? Also, can you explain the symptoms of not being to ssh into 'to-be-networking'? ssh -vv ubuntu@to-be-networking would be a good output to show. If that doesn't work, that is certainly a good place to start debugging.
    – dpb
    Commented May 12, 2016 at 18:53
  • I have physical machines. From the MaaS controller I 'ssh ubuntu@to-be-networking' and the authentication does not go through. I am currently trying to include userdata in cloud-init to give me another way to log into the machine. Thanks I'll turn on verbose. Good idea. Commented May 13, 2016 at 7:53

1 Answer 1

2

Check for DHCP lease exhaustion, in /var/log/syslog on the MAAS server.

1
  • Thanks. I reran it multiple times. After having moved my base image to 16.04 and rerunning several times it worked. (?) Commented Jun 6, 2016 at 2:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .