3

I recently installed STEAM and webcamstudio on my UBUNTU machine which is running a resolution of 1920 x 1080. I have found that these applications do not honor the system-wide font sizes, but use instead a different DPI which makes reading the menus very difficult as the text is very small.

Is there a way that I can change the settings so that the GUI font of these apps are not microscopic at this resolution?

3

Currently steam hardcoded the font size on linux.

The only way I found to increase the font size is to use a HiDPI skin

Installation:

  1. Open terminal
  2. cd to your steam skin directory (see note)
  3. Clone the repo(you must have git installed sudo apt-get install git)

    git clone https://github.com/MoriTanosuke/HiDPI-Steam-Skin.git

Then open Steam and go to Settings->Interface. Choose the new skin "HiDPI-Steam-Skin"

NOTE: The exact path to the skins might be different depending on your installation.

It might be located at ~/.steam/skins/ or ~/.local/share/Steam/skins/.

  • I seem to be stuck here with this solution. Steam does not recognize that this skin is available after I entered git clone https://github.com/MoriTanosuke/HiDPI-Steam-Skin.git in console. restarted Steam same problem. There is no option in Steam to change DIR for skins. – Kalamalka Kid May 26 '16 at 22:34
  • @KalamalkaKid Have you tried both folder '~/.steam/skins/' and '~/.local/share/Steam/skins/' – jrandiny May 27 '16 at 10:38
6

The skin (the accepted answer) is deprecated by the author, and it does not scale perfectly.

For those who are still looking for a good solution, there is actually a setting in steam to do that.

Simply check Steam->Settings->Interface->Enlarge text and icons based on monitor size and restart steam will give you a perfect text size.

  • this should really be the accepted answer, works perfectly – Dylan Cali Nov 9 '18 at 1:10
  • Does not work with Ubuntu 16.04 and the version of Steam I just installed. – Evan Nov 30 '18 at 7:40
0

It is probably caused by system default dpi scaling as i recently faced the same problem with sublime text 3. You should use default dpi that is '1'. if you change settings certain apps behave erraticly as they are made for certain resolutions and thus making a fuss in rendering process of gui.

To correct this just go to

System > Settings > Displays > Scale for menu and title bars

and change the scale to 1. this should solve the problem (restart your pc just in case :p ).

  • i am actually using 1.5 as my tv is huge and running at 1080p. The problem is these apps arent obeying the global DPI setting. – Kalamalka Kid May 26 '16 at 22:31
  • ya it is a pain. but try to use 1 or similar settings in which icons don't look shabby/blurred something like 1.35 or something like that. just play with it a little and you'll know. – Cruelplatypus67 May 27 '16 at 3:48
  • i dont think you understand. Some apps, like Steam and WebCamStudio are dont obey the global scaling factor, therefore become unreadable. This thread isnt about fixing the ones that do work (those are fine), its about apps like Wine and the ones i just mentioned that dont obey the scaling factor. – Kalamalka Kid May 27 '16 at 5:46
  • ah...sorry for the bad reply – Cruelplatypus67 May 27 '16 at 6:19
0

I was able to fix mine by going to:

System Settings -> Application Style -> GNOME Application Style (GTK)

and setting the font there for GTK themes to be the same as my system font.

Half my apps were fine, half were ugly fonts.

  • Where did you find the "Application Style" setting? – Evan Nov 30 '18 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.