1

I recently installed ubuntu 16.04 , after the installation seems like it takes more time to boot . On an average it takes 55 seconds to 1 minute . While checking the "dmesg" log I could see it gets hung at a particular place . I could understand it is somewhere related to network , but couldn't find solution online . I am copying the log below for reference . Please refer the screenshot also .

Note : But wifi and wired connections are working fine even though it takes long time while startup .

dmesg log :-

[   23.066941] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready 
[   23.451644] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready 
[   23.465563] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[   23.468922] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[   24.331301] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   30.254490] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[   30.258457] vboxdrv: Found 4 processor cores
[   30.276442] vboxdrv: TSC mode is Invariant, tentative frequency 2195011090 Hz
[   30.276446] vboxdrv: Successfully loaded version 5.0.18_Ubuntu (interface 0x00240000)
[   30.299706] VBoxNetFlt: Successfully started.
[   30.311334] VBoxNetAdp: Successfully started.
[   30.335055] VBoxPciLinuxInit
[   30.389282] vboxpci: IOMMU not found (not registered)
[   44.346552] Bluetooth: RFCOMM TTY layer initialized
[   44.346562] Bluetooth: RFCOMM socket layer initialized
[   44.346569] Bluetooth: RFCOMM ver 1.11
[   52.317088] wlp2s0: authenticate with 90:8d:78:86:8f:ca
[   52.349488] wlp2s0: send auth to 90:8d:78:86:8f:ca (try 1/3)
[   52.351196] wlp2s0: authenticated
[   52.352396] wlp2s0: associate with 90:8d:78:86:8f:ca (try 1/3)
[   52.356890] wlp2s0: RX AssocResp from 90:8d:78:86:8f:ca (capab=0x411 status=0 aid=1)
[   52.357115] wlp2s0: associated
[   52.357127] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready

dmesg log screenshot

Good to see an immediate response , thanks . I tried to turn off IPv6 , but it doesn't seem to make a change the booting time . I followed the below steps to turn off ipv6 , correct if was wrong .

Steps followed to turn off ipv6 : - 1. Edited /etc/sysctl.conf by adding below 3 lines in the end net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 2. sudo sysctl -p 3. Confirmed the value , cat /proc/sys/net/ipv6/conf/all/disable_ipv6 as "1"

but it didn't make a change .

Bluetooth , I tried I turned off and turned on . It has got no problem it loads faster I guess .

My "Motherboard" manufacturer is Toshiba :-

root@shafeeq-Satellite-C850:/home/shafeeq# dmidecode --type baseboard

dmidecode 3.0

Getting SMBIOS data from sysfs. SMBIOS 2.7 present.

Handle 0x0002, DMI type 2, 16 bytes Base Board Information Manufacturer: TOSHIBA Product Name: Portable PC Version: MP Serial Number: 1 Asset Tag:
Features: Board is a hosting board Board is replaceable Location In Chassis:
Chassis Handle: 0x0003 Type: Motherboard Contained Object Handles: 0

Sorry for a delayed replay . Actually I have never upgraded my BIOS since I bought my laptop (Toshiba staellite c850-i0011). Meanwhile I tried re-installing ubuntu and checked the boot time again , but no luck . I found something something strange , ie with systemd-analyse utility we can see the total time it took for boot (I found it online) . But it doesn't sync with dmesg log , I mean dmesg shows somewhat close to the actual time it takes . I really don't know it is related to "Desktop environment(Unity)" or "systemd" . I tried installing arch linux for testing the boot time , even in that it takes more time(more than 1 min) when I install GUI(desktop env -gnome 3 ) . Please let me know if you want see any specific system log , I can pull out and get you for analysis . When I was using old versions of ubuntu it used to be super quick :( .

systemd-analyse used to give close to 26-30 secs , but actually it takes 55-60 secs .

  • 1
    If not using IPv6 or bluetooth, you could turn those off. Is this a Gigabyte motherboard? IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards. GIGABYTE GA-970A-DS3 motherboard not working with 64 bit kernel - IOMMU GRUB_CMDLINE_LINUX="iommu=soft" ubuntuforums.org/showthread.php?t=2111223&page=5 – oldfred May 11 '16 at 20:56
  • Thanks "chili555" for the response . I already tried to turn off the ipv6 and bluetooth , but no effect . My motherboard manufacturer looks like Toshiba . I've posted the details , kindly correct me if I am wrong . – Shafeeq Rahman May 12 '16 at 7:03
  • Do you have latest UEFI/BIOS from Toshiba? This user just installed in UEFI mode to same system. Toshiba laptop C850 Windows 7 with upgrade to 8 version - sudodus ubuntuforums.org/… – oldfred May 12 '16 at 14:42
  • check Ubuntu 16.04 Very slow boot. – KernelPanic May 15 '16 at 6:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.