I can't install Ubuntu tweak on 16.04. I've had it on 4 previous versions of Ubuntu, so I know exactly what to do in order to install it, it just doesn't work on 16.04.

Is anyone having the same problem?

Can anyone help?


5 Answers 5


Although the program is now abandonware (I am sad too) there is a repackaged version which works on 16.04 announced in this article.

There is a ppa here

deb http://archive.getdeb.net/ubuntu xenial-getdeb apps

for which the key is

wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

Or you can just download the .deb from here

  • I'm getting deb: command not found. What's up with that?
    – wjandrea
    Jun 29, 2016 at 0:13
  • 1
    That line is not a command, it goes in your /etc/apt/sources.list Jun 29, 2016 at 0:32
  • I couldn't get it installed adding getdeb's repository. Does it really work? I needed to do these
    – Anwar
    Aug 31, 2016 at 9:15
  • It worked for me. What errors did you get? Aug 31, 2016 at 9:58
  • @OrganicMarble the dependency error of gir1.2-vte-1.90
    – Anwar
    Sep 3, 2016 at 13:07

Quick answer:

The program you're trying to install is abandonware (has been abondon and is no longer supported)... it isn't available for the latest Ubuntu (16.04). You would have to use one of the other tweak programs available for the later versions of Ubuntu such as:


Detailed Resolution

Alternatively ubuntu-tweak-tool has been repackaged of which you can find detailed installation instructions here:
How can I install Ubuntu tweak on Ubuntu 16.04

Another alternative of this gir1.2-vte-2.90error been reported to bugs.launchpad.net, where one of the users has described a method and provided files to make it run on Ubuntu 16.04. Hist direct entry in the bug report is: https://bugs.launchpad.net/ubuntu-tweak/+bug/1555706/comments/5

He has included a video report of how to use his resolution.

  • It is still available from getdeb.net for 16.04. See my answer. Nov 8, 2016 at 20:11

As L. D. James has already answered that Ubuntu tweak is discontinued and you better use other alternatives like Unity Tweak tool or Gnome Tweak Tool, but If you really want to use Ubuntu tweak on Xenial Xerus (16.04), here is the procedure. But, be warned that, many of the functionalities may not work properly.

1. Add GetDeb repository

I can see that you already downloaded Ubuntu Tweak's deb file. however, for others they need to add GetDeb's repository. Since this is the only repository still providing builds for Ubuntu Tweak (afaik).

Here is the procedure to add Getdeb's repository. http://www.getdeb.net/updates/Ubuntu/16.04#how_to_install

The easiest way is just downloading getdeb package and installing it with

sudo dpkg -i getdeb-repository_0.1-1~getdeb1_all.deb

2. Create a package that provides gir1.2-vte-2.90

You can skip building of this proxy package by downloading my built one (If you trust of course). Here is the dropbox link of that package .deb file. If you download .deb file, you can skip step 1, 2 and just install the package by following step 3.

Some Background:

Ubuntu 16.04 has the package gir1.2-vte-2.91. If you don't have it already installed, install it with

sudo apt install gir1.2-vte-2.91

Now, This package is a higher versioned of gir1.2-vte-2.90 upon which Ubuntu Tweak depends. But since the version number is included in the package name, apt is failing to treat gir1.2-vte-2.91 as a higher version of gir1.2-vte-2.91. But a package gir1.2-vte-2.91 should really work in place of it.

So, our idea is, we will create a package that will provide gir1.2-vte-2.90, because we know, What Ubuntu Tweak needs is already in our system via gir1.2-vte-2.91.

Let's start.

  1. First install equivs

    sudo apt install equivs
  2. Then create a control file for our provider package gir1.2-vte-2.90-provider

    equivs-control gir1.2-vte-2.90
  3. Step 2 will create a file named gir1.2-vte-2.90. Open it and replace it's content with these lines

    Section: misc
    Priority: optional
    Standards-Version: 3.9.2
    Package: gir1.2-vte-2.90-provider
    Version: 1.0
    Depends: gir1.2-vte-2.91
    Provides: gir1.2-vte-2.90
    Description: A proxy provider for gir1.2-vte-2.90 package
     A proxy provider for gir1.2-vte-2.90 package
  4. Now use this command to generate the package

    equivs-build gir1.2-vte-2.90
  5. Install newly generate package with dpkg

    sudo dpkg -i gir1.2-vte-2.90-provider_1.0_all.deb

3. Install Ubuntu Tweak

  1. Now go to GetDeb's Ubuntu tweak page http://www.getdeb.net/software/ubuntu-tweak

  2. Click on Install this now button.

  3. A dialog will popup requesting permission to install package. Allow it.

Ubuntu tweak should be installed on your Xenial!

  • quite a work! +1, Have you tested it? Is it fully functional?
    – sourav c.
    Sep 3, 2016 at 3:54
  • @souravc Of course I've tested it and I'm using Ubuntu Tweak in 16.04. As per functionality, most of them works except the Apps Tab.
    – Anwar
    Sep 3, 2016 at 4:03
  • 1
    In 16.04 Software center is replaced by GNOME Software app. That may be the reason why apps tab is not working. I will give a try. Thanks.
    – sourav c.
    Sep 3, 2016 at 4:20
  • It is still available from getdeb.net for 16.04. See my answer. Nov 8, 2016 at 20:11

This worked for me. To download and install Ubuntu-Tweak for Ubuntu 16.04 do the following:

  • Highlight, right click, and copy the code below:

    wget http://archive.getdeb.net/ubuntu/pool/apps/u/ubuntu-tweak/ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb
  • Open your terminal with Ctrl+Alt+t at the same time or right click into a folder and left click open in terminal

  • Paste the code into your terminal with Ctrl+Shift+v or right click into the terminal and the click paste
  • Hit enter.
  • Double-click the file ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb in the folder.

Software Center opens up, click install, type in your password when asked and hit enter.



Good day! I noticed, that some links don't work on this post now and I found one site, where you can exactly find the necessary program:

I hope this information will be useful for comunity!

  • Ubuntu Tweak has been deprecated. This is very unfortunate, I really liked it enough to fix it after it had been discontinued. You can still install it, but you would go through a bunch of installing more deprecated software to do it. dep·re·cate /ˈdeprəˌkāt/ Learn to pronounce verb past tense: deprecated; past participle: deprecated 1. express disapproval of.
    – The Wise
    Oct 15, 2019 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.