1

My sound has been working fine until recently.I lost sound and the sound control on the menu bar.When I reboot all I get is a clicking sound. When I managed to get back the sound control, it had an x against it. When I clicked on it the sound was muted and I could not unmute it.

Also my sound card was not there any more, where it had been before. My sound returns by clicking on the Ambient Noise icon. I've looked around the internet for answers and tried a few things without success. Does the following mean anything to anyone?

sudo apt-get install indicator-sound   
[sudo] password for martin: 
Reading package lists... Done 
Building dependency tree       
Reading state information... Done 
The following packages were automatically installed and are no longer required: 
  libhdb9-heimdal libkdc2-heimdal libntdb1 libtimezonemap1 
  linux-headers-3.19.0-25 linux-headers-3.19.0-25-generic 
  linux-image-3.19.0-25-generic linux-image-extra-3.19.0-25-generic 
  python-ntdb signon-keyring-extension 
Use 'apt-get autoremove' to remove them. 
Suggested packages: 
  unity-greeter-session-broadcast 
The following NEW packages will be installed 
  indicator-sound 
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade. 
Need to get 0 B/62.7 kB of archives. 
After this operation, 379 kB of additional disk space will be used. 
Selecting previously unselected package indicator-sound. 
(Reading database ... 389788 files and directories currently installed.) 
Preparing to unpack .../indicator-sound_12.10.2+14.04.20140401-0ubuntu1_amd64.deb ... 
Unpacking indicator-sound (12.10.2+14.04.20140401-0ubuntu1) ... 
Processing triggers for libglib2.0-0:i386 (2.40.2-0ubuntu1) ... 
Processing triggers for libglib2.0-0:amd64 (2.40.2-0ubuntu1) ... 
Setting up indicator-sound (12.10.2+14.04.20140401-0ubuntu1) ... 

I'm a fairly new user, so as indicated above, do I need to delete some unwanted files to bring back the sound control?

0

Install the indicator-sound package which provides the normal ubuntu volumecontrol via the command

sudo apt-get install indicator-sound

and to make the change take effect do

killall unity-panel-service

if this didn't work than run following command in terminal

gsettings set com.canonical.indicator.sound visible true

and you will be good to go

  • Can you make it a bit clearer please. – Martin May 13 '16 at 12:04
  • when I enter killall unity-panel-service, nothing happens. Do I need to add something? – Martin May 13 '16 at 12:06
  • My sound indicator randomly vanished. The gsettings worked for me, thanks Nitesh, but why did the sound indicator vanish in the first place I wonder. – barry May 17 '16 at 8:10
  • well if it worked, don't forget to accept the answer. – Sinscary May 17 '16 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.