1

I've just installed Lubuntu 14 on an older machine (Dell Optiplex 780). Everything works fine on the live-USB drive, installation etc. When the machine boots to the newly installed operating system, neither the keyboard nor mouse work. I've ruled out the following:

  • I have tried all USB ports.
  • I have tried both an HP and apple keyboard, and a logitech mouse.
  • Re-plugging the devices in after boot does not help.
  • Toggeling BIOS compatibility flags does not resolve the issue
  • All USB ports are enabled in the BIOS.
  • Machine is not frozen, it can respond to the power button and goes to sleep after a defined period.
  • The machine is not using USB3.0 ports
  • Linux Mint and Ubuntu install without issue

The following reports are similar:

It is unlikely to be identical to bug 1244176 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1244176 because it does not occur during install.

Workaround: install Linux Mint

Edit: it occurs to me that the images I'm using to install are retrieved from unetbootin on OSX. They may not be current. I will try a different image tomorrow.

Edit: There are far worse problems now. The system is sporadically not booting, refusing to boot from live-USB, and sometimes keyboards aren't even working in the BIOS. I am giving up. Something is terribly wrong.

  • Unetbootin is retrieving images from the internet. Maybe the connection is intermittent or there is a server connection problem. Anyway, download the ISO file first from the author's site, check it against its' checksum file (for integrity), then use unetbootin to write the ISO file to USB device. – ipse lute Jun 9 '16 at 12:11
1

I believe that the program unetbootin silently fails to produce a valid bootable installation disk. Installing from the corrupted disk appears to succeed, but falls short of installing the full system, leading to hard to diagnose errors.

Unetbootin may not work with all distros [e.g. 1 2 3], or all images of a given distro. I suspect it also may fail somewhat stochastically, e.g. if a sporadic disk error is encountered, it may fail silently, but succeed if no errors occur.

My recommendation for anyone experiencing similar weirdness is to create the bootable USB directly, on the command line, and to avoid unetbootin completely. The commands I used on OSX to create an installation disk are

hdiutil convert -format UDTO -o DOWNLOAD_LINUX_INSTALLER.iso
sudo diskutil unmount /Volumes/VOLUMENAME/
sudo dd if=DOWNLOAD_LINUX_INSTALLER.iso.cdr of=/dev/disk#

Where disk# should be replaced by the device file for your USB drive. On my system it was disk1.

  • Welcome to Ask Ubuntu. Glad you worked it out. I wish people would stop using unetbootin, especially when they have dd available. :) – chaskes Jun 9 '16 at 12:08
  • It's a good answer, but it does not explain why Ubuntu and Mint worked fine , and Lubuntu didn't. I believe there is some problem with the Lubuntu image, not with unetbootin. – ipse lute Jun 9 '16 at 12:15
  • I agree that some mystery remains. I'm almost completely convinced that the problem was a corrupted Lubuntu installation. For reasons that make no sense to me (why can't unetbootin just wrap dd with some checksum verification and be done with it?) unetbootin will work on some distros and not others. Furthermore, it may work on some images of a distro and not others. Finally, it is possible that there was some emergent failure in my USB drive, that unetbootin could not detect. – MRule Jun 9 '16 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.