2

12.04 (EOL April 2017) and 14.04 (EOL 2019) both appear to use openssl 1.0.1, which is apparently not going to be supported at all after December 31, 2016 (according to openssl.org/source).

Will security fixes be backported into the openssl packages running on 12.04 and 14.04 for as long as those versions are supported? Or will a version upgrade (e.g., to 16.04 for LTS) be required?

1

If you read https://help.ubuntu.com/community/Repositories#Components you'll see that:

When you install software from the main component, you are assured that the software will come with security updates and that commercial technical support is available from Canonical.

OpenSSL is from the Main component, therefore you are assured security updates until EOL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.