0

When I installed Ubuntu 16.04 I put it on a 250 GB SSD and created a 4 GB swap partition. Recently I have been doing some machine learning and I keep using up all of my 16 GB of memory. I decided to add a 120 GB SSD I had laying around and use it as a dedicated swap drive. I made the following changes in /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=85206e1d-5f22-431d-8d17-bdc001895a8c /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=E478-855C  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda2 during installation
#UUID=ea40886f-8938-4629-b03d-ef30d5ff28c2 none            swap    sw              0       0
UUID=c23607a3-093e-4e2a-a34a-4ba10b6b603d none            swap    sw              0       0

As you can see I commented out the first swap drive and added the second one which is my 120 GB SSD. The issue I am having is now Ubuntu mounts both drives as swap. I do not want it to use the original 4GB partition on the boot drive. I can manually turn off the swap for the boot drive using the disks manager but I want a solution which occurs automatically at boot.

1

Try using gparted.

sudo apt-get install gparted

Right click your swap partition and select swapoff.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.