0

I tried instaling ROOT by CERN by following steps described by certain people. But although that was unsuccessful, I keep getting the following line when I open a new terminal.

bash: /home/USER/bin/thisroot.sh: No such file or directory

How can I remove that? EDIT- Please note, for those who have raised the doubts, that I have redacted my true username. And I wrote USER in that place.

  • Look in .bashrc in your home directory. – Jos May 11 '16 at 13:12
  • 1
    Is it literally the string "USER" or are you redacting personal information? – glenn jackman May 11 '16 at 13:31
  • redacting my username. – MycrofD May 11 '16 at 16:20
1

There's probably an alias on your .bashrc or .bash_profile calling that file, so it tries to load it everytime you get a new prompt.

Try editing them with one of these commands:

gedit $HOME/.bashrc
gedit $HOME/.bash_profile
gedit $HOME/.profile

Look for any line loading 'thisroot.sh' and comment it (write a # character at the begining of those lines). If you see after saving and opening a terminal that all works well, you can go ahead and directly deleting those lines.

Also, the way the script is being called sounds wrong, shouldn't it be /home/YOURUSERNAMEHERE/bin/thisroot.sh?

| improve this answer | |
  • 1
    yes, of course, it is "myusernamethere"... ;-) I am just redacting my personal information. – MycrofD May 11 '16 at 16:23
  • 1
    the first statement solved my problem. many thanks ! – MycrofD May 11 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.