I just upgraded a 14.04 machine to 16.04 (64bit - Gnome-Shell).

The upgrade worked without obvious issues. After finishing the upgrade and rebooting the machine i am not longer able to start VMware Workstation 11.1.3 (which worked on this machine before with 14.04).

Clicking the VMware Workstation launcher/icon in plank (yet another dock) results a short visible vmware entry in the Gnome panel which then disappears.

Starting vmware from terminal gives no output and the workstation GUI doesn't appear. The terminal returns to the prompt without output.

I was wondering if i should try to reinstall workstation but decided to ask first

Any help is appreciated


  1. Uninstall & reinstalling vmware workstation had no effect
  2. Starting vmware from terminal via

    env VMWARE_USE_SHIPPED_LIBS=1 /usr/bin/vmware

Results at least in some output and reaches the moment where it wants to compile its modules & load into the kernel.

This ends with an error

 Loop on signal 11

This happens for my main user and as well if i start vmware with sudo privileges.

Content of /var/log/vmware/hostd.log can be seen here.

  • Have you tried to re-install Workstation? Before doing that make backups of your virtual machines.
    – Gen
    May 12, 2016 at 6:15
  • Yes - did that - without effect
    – dufte
    May 12, 2016 at 6:43

2 Answers 2


After doing a big amount of tests including uninstall & reinstall ,removing preferences and rebuilding modules i found the following solution.


export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH


echo /usr/lib/vmware/lib/libglibmm-2.4.so.1 | sudo tee -a /etc/ld.so.conf.d/LD_LIBRARY_PATH.conf
sudo ldconfig

As a result i am again able to start vmware by



Please see the answer of @Michael Firth as it might be a better/cleaner approach.


As a variation on dufte's answer, I was able to get it working again by adding the

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH

Line into /usr/bin/vmware and /usr/bin/vmware-netcfg, which are both actually shell scripts.

I was nervous of the other option, as it changes the library behaviour for all things on the system, rather than just VMware

  • 1
    Yes, very good idea to consider that and to find an elegant solution. +1 Jan 5, 2017 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .