0

I'm trying to install Ubuntu on my old Macbook Pro 3,1. I have tried to install the following versions: 16.04, 14.04 and as last 15.10. (this one is still installed)

On my work I used 'Startup Disk Creator' in Ubuntu 15.10 to create an installation disk on an external SSD. The iso files are downloaded from the original ubuntu website. And selected the amd64 desktop versions (not mac versions).

When booting from my external SSD installation disk. In the grub menu I had to press 'e' to edit the boot command. Because without de option nomodeset Ubuntu would not start and the installation would not begin.

I have first tried to install Ubuntu with the option "Erase disk and install Ubuntu". But when I did this my MacBookPro did show a folder with a question mark (?). So I had to tried something else:

I started Ubuntu from my external SSD installation disk with nomodeset on. Here I configured my internal SSD with the following structure:

  • /dev/sda1 | fat32 | 512MB | (efi)
  • /dev/sda2 | ext4 | 1024MB | (boot)
  • /dev/sda3 | lvm2 pv | remaining GB | (vg0)
    • (lv)home | 50GB
    • (lv)root | 30GB
    • (lv)swap | 8GB

Then I started the installer and selected "Something else" for installation. In this installation I selected the correct partitions efi, boot, root, home and swap and configured them for the installation.

When the installation was done, I booted the machine and it "freezes" with a purple screen. In this purple screen I cannot use ALT + F2 for a terminal screen. (I tried more combinations of course, like the 'fn' key). And I have waited, but no change will appear in this purple screen state.

I have tried to set the nomodeset and noapic in the /etc/default/grub file or configured the DEFAULT_RUNLEVEL=(1, 2 or 3) in the /etc/init/rc-sysinit.conf file of the lv(root) but no success either.

How can I fix this?

Thanks in advance!

0

After searching and reading many forums, and testing many options i figured out my problems:

  • Because I could not boot from the internal disk I had to add the nomodeset to the /boot/grub/grub.cfg file. Then I could boot from the internal disk. (after the boot without the external SSD you can use update-grub So it fixes the grub.cfg properly. DON'T forget to add nomodeset to the /etc/default/grub file!)
  • But when I could boot from the internal disk I could not install the video driver (nvidia). After searching some forums the problem is that the BIOS config could not be reat/written by the EFI partition.
  • The solution to this problem is written in this tutorial here
  • With GRUB_GFXPAYLOAD_LINUX=1440x900 in the /etc/default/grub file the tty's and splash screens wil run in the correct resolution.

After some little fixes my MacBookPro 3,1 is running only Ubuntu 16.04 with the proprietary tested nvidia drivers that Ubuntu serves.

Me Very happy

| improve this answer | |
  • I have a macbookpro3,1 as well. But I am having issues getting Nvidia to work properly. Which part of the tutorial did you apply? There 3 different answers there. – Giovanni Caligaris Jan 13 '17 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.