My prefered browser: Chromium My prefered download manager : uget+aria2

When I download a Google Drive folder shared to me, Chromium automatically downloads it by its default download manager. Problem is the size is really huge. So I got to have some resume support.

Link is like https://doc-00-1s-docs.googleusercontent.com/docs/secure/bla bla bla bla.

So when I copy the link to uget, or aria2 in terminal... a ServiceLogin.html file gets downloaded.

I have no luck with wget via terminal as well.

So what could be the easy way?

  • Ask your friend to split the file into pieces, for example using 7zip. – fkraiem May 11 '16 at 11:51
  • 1
    sorry, it took him 2 days just to upload the file. There has to be another way.. What is ServiceLogin html file. Is it being downloaded because it fails to verify my google login when i use download via uget or aria? Because if i use the same link again in chrome it works and downloads it via its default download manager. – nazar2sfive May 11 '16 at 11:58
  • Life is long, two days is nothing. – fkraiem May 11 '16 at 11:59
  • Have you tried a download manager add-on, like e.g. chrome.google.com/webstore/detail/chrono-download-manager/…? This one claims to replace the built-in download manager and has resume support. – Jos May 11 '16 at 12:37
  • there used to be days when uget plugin was available that directs the link to uget . The link used to work in the past, well around 3 yrs back. – nazar2sfive May 11 '16 at 12:43

I had the same issue downloading files using downloaders. The issue is when you are logged in with any Gmail account, google generates a different link. What I do is, I generate a shareable link and open that link in incognito mode, then just added the link to downloader and it works. And now the download link generated is a different one.

More Clear Solution (Changed)

  1. Open Browser in Private/incognito mode
  2. Open the download url for example it is "https://docs.google.com/uc?id=0B08CMVb2YK_EMkUyRmc4a0NtazQ&export=download"
  3. File size is larger so it will show you warning just click Download anyway the file will start downloading.
  4. Now goto downloads and copy real link form it, that will be like "https://doc-10-4c-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/eia3v63medr04gs1ralifdfml72cmc8k/1469383200000/0595560048316020307/0B08CMVb2YK_EMkUyRmc4a0NtazQ?e=download". For each time/session you will get changed/new link
  5. Now add this link to the uget/idm/xdm it will start downloading.

Tools Info UGet+ Chrome

  • 1
    You don't make sense. – fosslinux Jul 23 '16 at 20:14
  • 2
    try it and let me know if you have same problem as title says. it will make you sense – Azmat Karim Khan Jul 24 '16 at 18:48
  • "For each time/session you will get changed/new link" - isn't this a problem? How is this an answer if the problem is still there? – Mladen B. Dec 7 '16 at 12:06
  • new link is based on time you requested download that have some expiry date , that means the link is valid for some time (let's say 1day). if you want to resume the download and the link is expired , many download have refresh link option so you won't loose the previous progress. – Azmat Karim Khan Dec 8 '16 at 20:26
  • 1
    you should get the latest link again and update the download uri. – Azmat Karim Khan Jan 15 '17 at 21:14

What worked for me was:

  1. Open Browser in Private/incognito mode
  2. Open the download url for example it is https://docs.google.com/uc?id=0B08CMVb2YK_EMkUyRmc4a0NtazQ&export=download
  3. File size is larger so it will show you warning just click Download anyway the file will start downloading.
  4. Make sure download starts in your browser (I used Firefox 51).
  5. Go to downloads (Ctrl + J) copy the link and don't stop the download yet!
  6. Paste the link in your download manager, (I used FDM)
  7. Soon as download begins in your manager feel free to stop the download in the browser.
  8. If the download stops for some reason, just go through the above steps again, and replace the old download link with the new one in your download manager and resume!
  • so what is difference with above answer? – Azmat Karim Khan Aug 28 '17 at 11:14

Actually this might solve the issue in a clever & useful way

Tools used:

  • wget
  • uGet (or any other Download Manager)

Things to do:

  • Open terminal
  • Set this command -> nano ~/.bash_aliases
  • Copy and paste this function into the terminal

    gdrive_download () {
      CONFIRM=$(wget --quiet --save-cookies /tmp/cookies.txt --keep-session-cookies --no-check-certificate "https://docs.google.com/uc?export=download&id=$1" -O- | sed -rn 's/.*confirm=([0-9A-Za-z_]+).*/\1\n/p')
      wget --load-cookies /tmp/cookies.txt "https://docs.google.com/uc?export=download&confirm=$CONFIRM&id=$1" -O $2
      rm -rf /tmp/cookies.txt
  • Save file by pressing Ctrl+X

  • On terminal, call the function (this is an example)

     gdrive_download long_google_drive_file_id filename.ext
  • Once it run, you will see an url "https://..."

  • copy and paste this url in your uGet > New Download > URI
  • Enjoy.

Tested to this date.

The function gdrive_download comes from vladalive's comment, using the one-line command from beliys.

They're whom deserve such credit.

  • I think it may work, the gist itself is actually incomplete, the comments there have the full answer! I will see if I can make it work :) – Aquarius Power Jan 25 at 1:46

Updating my IDM to the latest version did the trick for me. Once I updated IDM to the latest version it automatically added an extension to chrome. I, then restarted chrome in normal mode, pasted the url and hit on "Enter" and IDM popped up with the proper link for the file to be downloaded. I'm happily downloading the file with IDM now. The file size is approx. 2.5 GB.

Hope this helps.


Tools :

  • cookies.txt extension
  • any download manager accept ccokies files (I use aria2)

Steps :

  • Download cookies of the tab.
  • load the cookies to the download manager (I am using aria2).
  • Start download.


aria2c --load-cookies=cookies.txt  <Download-Url>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.