2

I'm on Xubuntu 14.04.

I ran sudo apt-get install unity. It ran successfully.

But when I log out, I don't get the option to log in again with Unity. This is what I see:

enter image description here

I have tried rebooting. Did I miss something?

  • What do commands stat /usr/share/xsessions/ubuntu.desktop and which unity tell you ? – Sergiy Kolodyazhnyy May 11 '16 at 8:38
  • @Serg They give stat: cannot stat ‘/usr/share/xsessions/ubuntu.desktop’: No such file or directory and /usr/bin/unity respectively. – Revetahw says Reinstate Monica May 11 '16 at 8:55
1

The sessions typically are listed on the login screen if they are read from .desktop files provided in /usr/share/xsessions folder. On my system ( default Unity desktop ) I have the following ubuntu.desktop file :

[Desktop Entry]
Name=Ubuntu
Comment=This session logs you into Ubuntu
Exec=gnome-session --session=ubuntu
TryExec=unity
Icon=
Type=Application
X-LightDM-DesktopName=Unity
X-Ubuntu-Gettext-Domain=gnome-session-3.0

I suggest you add the following file , but remove the Icon= part and perhaps X-LightDM-DesktopName=Unity

| improve this answer | |
  • Just to clarify, you're saying i should create a file called ubuntu.desktop in my /usr/share/xsessions folder and paste that text into it? (except for the lines you mentioned?) – Revetahw says Reinstate Monica May 11 '16 at 9:24
  • 2
    @Fiksdal yes, that's exactly what i am saying – Sergiy Kolodyazhnyy May 11 '16 at 9:27
  • I did that. It did give me "Ubuntu" as one of the options. I selected it and logged in, but now I'm getting only the wallpaper and a mouse cursor. I think I'll try a reboot. – Revetahw says Reinstate Monica May 11 '16 at 9:34
  • 1
    @Fiksdal um , install compizconfig-settings-manager and find the Unity plugin. click on that, and there will be an option to the left to enable it. Do that. In reality , Unity is just a plugin for compiz. From time to time it just crashes for whatever reason and you have to reenable that plugin. No more no less - Unity is just a plugin – Sergiy Kolodyazhnyy May 11 '16 at 9:49
  • 1
    @Fiksdal well , I have over a thousand answers already on AskUbuntu, but some of the big and useful scripts , I put on my github.com/SergKolo/sergrep – Sergiy Kolodyazhnyy May 11 '16 at 14:23
0

Try:

sudo apt-get --purge remove unity

Then reinstall unity BUT THIS TIME WHILE INSTALLING IF A SCREEN POPS UP ASKING YOU TO CHOOSE BETWEEN "LIGHTDM" AND SOMETHING ELSE, CHOOSE "LIGHTDM".

| improve this answer | |
  • But no such screen popped up when I installed Unity the first time, so why would it pop up if I purge and reinstall? – Revetahw says Reinstate Monica May 11 '16 at 9:15
  • This same action can be achieved by doing sudo dpkg-reconfigure lightdm – Sergiy Kolodyazhnyy May 11 '16 at 9:28
  • @Serg Is dpkg-reconfigure worth trying? – Revetahw says Reinstate Monica May 11 '16 at 9:36
  • 1
    @Fiksdal no , because what Xubuntu is using , I believe is a variation of lightdm , so you won't have other choices there. If you install gnome, then sure, you will have another option. This however is also pointless because it changes which login screen you see by default, it doesn't affect the session options , AFAIK. – Sergiy Kolodyazhnyy May 11 '16 at 9:45
  • I had installed unity on ubuntu gnome and it worked fine – ShuaibKunji May 11 '16 at 10:21
0

Try

sudo apt-get --purge remove unity

and

sudo apt-get install ubuntu-desktop

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.