0

There are some applications that are not available for Linux, e.g. Trello or Sunrise Calendar. As long as there is a Chrome App available as an alternative, it doesn't matter much.

However, since I upgraded to 16.04, Chrome Apps do behave differently than with 14.04, 14.10, 15.04, 15.10. They have no unique app icon anymore but show the Chromium standard icon instead. And they are not available via Dash search anymore, which they used to be in the releases mentioned before.

How to make Chrome Apps behave like native apps in Ubuntu 16.04 again?

  • I'm pretty sure it worked for me when I was on 16.04 (I had to downgrade back to 14.04 due to more serious bugs). Do you create the shortcuts from the Apps tab (chrome://apps) or from the particular page itself? I'm sure I did this from several sites (Google Keep, Facebook Mobile, Messenger) and probably also from Apps (Google Docs) and it worked fine. I had Google Chrome 64bit (not Chromium). – jena May 16 '16 at 8:55
2

It looks like the problem your referring to is a bug in Chromium. Until it is fixed you could use Google Chrome which does not have this bug.

Update: Now the bug is fixed for me with the latest version of Chromium.

| improve this answer | |
  • Alright, I'm gonna check this with my system – Bunjip May 18 '16 at 20:20
0

If you upgraded from previous release (it sounds you did) you may try to clear your config files with

mv ~/.config/google-chrome ~/.config/google-chrome-backup

and maybe also clear the app shortcuts with

mkdir ~/.local/share/applications-backup && mv ~/.local/share/applications/chrome* ~/.local/share/applications-backup

(both commands should create a backup of those config files).

Since the feature in question worked for me after fresh install of 16.04 I suspect some debris from your previous installs may cause your issue.

| improve this answer | |
  • Although you're right that my question really sounds like I've updated from previous version to 16.04, matter is, that I refer to installs on different machines. The one in concern running 16.04 has gotten a fresh install of 16.04. – Bunjip May 18 '16 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.