3

after I upgraded Ubuntu Gnome 15.10 (Wily Werewolf) to 16.04 (Xenial Xerus), I cannot start synaptic or aptitude for installing new software, and 'apt-get install whatever' does not work either. Here is the error I always get:

The value 'wily is invalid for APT::Default-Release as such a release is not available in the sources.

I read a lot about this error on Google etc., but the solutions proprosed on the web only work for older versions of Ubuntu or Debian. What I tried e.g. was checking the value of APT::Default-Release within /etc/apt/apt.conf, but it is not set there, it is not set in any text file within /etc/apt/ or any of its subdirectories. I removed all files from the directory /etc/apt/sources.list.d, because these were related to older Ubuntu versions.

Anymore ideas?

P.S. 1: A bit more information about my environment:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial

P.S. 2: Output from sudo apt edit-sources (removed commented lines):

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse

deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://archive.canonical.com/ xenial partner
  • 1
    Please check your version using 'lsb_release -a' and add the output to the above post. In addition run 'sudo apt edit-sources' (opens your sources in default editor) and paste the output as well. For me it sounds like your apt sources do refer to wily sources instead of xenial – dufte May 11 '16 at 7:29
  • 1
    I would try to move '/root/.synaptic/synaptic.conf' to '/root/.synaptic/synaptic.conf.backup' and see if that helps. Assuming there are errors in synaptic.conf. If it doesnt helps - revert the change. – dufte May 11 '16 at 7:52
  • Did that too, but still doesn't work :-/. – Gerhard Hagerer May 13 '16 at 7:12
  • Just 'sudo apt clean'? – emk2203 May 13 '16 at 13:09
  • Which server you are using to download programs? "System Settings" -> "Download from" section? Maybe selecting it to main server can be good. – al0s May 13 '16 at 13:28
0
+50

If you have problems with a "stuck" apt or the higher-level programs aptitude or synaptic, a cleaning of the apt cache may be necessary.

This is especially the case after a distribution update.

sudo apt clean

is quick and easy and helps with a lot of stuck apt systems. I do it routinely after a lot of updates have been made, or after a dist-upgrade.

1

Open /etc/apt/apt.conf.d/01ubuntu using nano, like

sudo nano /etc/apt/apt.conf.d/01ubuntu

Then , type the following as it is:

APT::Default-Release "xenial";

Clean your apt cache by running:

sudo rm -rfv /var/lib/apt/lists/*

Then create the the partial folder which was removed by the previous command:

sudo mkdir -pv /var/lib/apt/lists/partial

To make sure, that you have cleaned your lists, run the following command:

sudo apt clean && sudo apt autoclean

Now, update your repository information:

sudo apt update --fix-missing

This should fix your errors.

  • Well, your answer looks quite elaborated, but the other guy's been first, sorry. – Gerhard Hagerer May 14 '16 at 20:45
  • I did upgrade from 15.10 to 16.04 but I can't find /etc/apt/apt.conf.d/01ubuntu on my machine. should I create it ? – Cristiano Jul 26 '16 at 18:40
  • @Cristiano Yes, you can manually create the file. Apt will automatically load the settings of the file. – Abhimanyu Saharan Jul 26 '16 at 18:42
  • thanks @AbhimanyuSaharan, but unfortunately I'm still getting the annoying message:"The value 'trusty-proposed' is invalid for APT::Default-Release...". Do you know where this value is set ? I'm running xenial. – Cristiano Jul 26 '16 at 19:55
  • @Cristiano Try running grep command to search for the file. grep trusty-proposed /etc/apt/* I have not tested this command but see if it helps you – Abhimanyu Saharan Jul 27 '16 at 3:37
0

that mirror was broken untill earlier this morning , see the date and time on the Xenial folders. It should work now.

http://ubuntu.mirror.lrz.de/ubuntu/dists/

Its best to use the standard redirector for your country instead as it would not have included a broken mirror.

http://de.archive.ubuntu.com/ubuntu/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.