After upgrading from 15.10 to 16.04, when I switch wifi networks using the network manager applet, all networking capability is lost. Before selecting the different wifi network, the wifi works perfectly. After I lose connection, I can restart the wifi using sudo systemctl restart network-manager.service. But I can't switch networks.

At the bottom of this post is a screenshot showing what the applet looks like after the attempt to switch networks: no wifi networks are visible from the applet's list, and the applet reports "device not ready."

Here is the output from lspci -knn | grep Net -A2; rfkill list:

03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 6b)
    Subsystem: Intel Corporation Dual Band Wireless-N 7260 [8086:4160]
    Kernel driver in use: iwlwifi
0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

The results of modinfo iwlwifi | grep 7260 are:

firmware:       iwlwifi-7260-13.ucode

Please note that this is unrelated to the commonly reported bug that wifi does not work on resume from suspend. There are at least three solutions to that issue here. I tried all of those suggestions, plus I also installed network-manager_1.2.0-0, all to no avail.

The issue I am requesting help on is specifically that wifi completely stops working whenever I attempt to switch networks.

I am adding a bounty and the results from the wifi script on ubuntuforums. Also, please note that I installed iwlwifi-7260-17.

I also am aware of the suggestions in bug report #1574347 (I posted on that report on post #8, although I think that the bug report is for the suspend-resume issue not my changing APs issue). In all events, I tried the suggestions to upgrade network-manager and network-manager-gnome (see post #42), to no avail.

I also am aware of bug report #1311257 and the suggested script to fix that bug. I implemented that script and regressed back to the suspend-resume issue.

Network Manager applet

  • There are bugs to be fixed in network manager in bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347, although this bug does not look exactly the same as your symptom but may worth trying the proposed packages as stated in the bug, to see if they can fix yours. – Anthony Wong May 14 '16 at 8:51
  • I tried the solutions provided until today's date (upgrading network-manager and a few others to 1.2.0-0ubuntu0.16.04.1). It did not solve the problem. Thanks though. – Rsync May 15 '16 at 3:22
  • If there is no typo in the version number, you should really try 1.2.0-0ubuntu0.16.04.2 (notice the last digit), that is what fixes bug#1574347, see the changelog in launchpad.net/ubuntu/+source/network-manager/…. – Anthony Wong May 15 '16 at 4:43
  • It was a typo -- sorry. For network-manager, the version I installed is 1.2.0-0ubuntu0.16.04.2 (as per the suggestion in bug#1574347). But the version of network-manager-gnome in the bug suggestion, and the one I installed, is 1.2.0-0ubuntu0.16.04.1. Also, post #48 in the bug report indicates that the solution doesn't work for Intel 7260. – Rsync May 15 '16 at 14:52
  • Please edit your question to include the bug number and mention that post #6 is you so other people don’t go down the blind alley I did. I also did not understand your comment 3 hours ago. Can you make it clearer. – Steve Roome May 15 '16 at 18:17

You have upgraded to the latest LTS version of Ubuntu, and like many you have been having problems with Wi-Fi. You experienced loss of Wi-Fi on resuming from suspend. This was due to bug 1574347, bug 1311257 or some combination of the two. You found a workaround that worked. However when you switch networks you again lose Wi-Fi connectivity with NetworkManager not seeing any Wi-Fi access points. What should you do?

The following is the approach I would recommend.

  1. Research the problem
  2. Ask for help
  3. Raise a bug report
  4. Seriously consider whether you need the latest LTS version of Ubuntu
  5. Try an alternative to GNOME Network Manager
  6. Control your Wi-Fi from the terminal.

Step 1 You tried researching the problem. You did not find anything about this issue on the internet.

Step 2 You posted this question on Ask Ubuntu. You posted the results of running the Ubuntu Forums WiFi diagnosis script and a screenshot of your screen. When you did not get a response you posted a bounty on the question. All great moves on your part. We have chatted about your problem and I have analysed your WiFi script results in detail. Apart from a couple of kernel error messages apparently related to the suspend/ resume issue the results show working Wi-Fi that is just not connected to an Access Point.

Step 3 This is clearly a bug in GNOME Network Manager so create a bug report. The developers need bug reports to find an eliminate errors in the code. You do this by typing ubuntu-bug network-managerin a terminal.

Step 4. Seriously consider reverting to your previous version of Ubuntu. Adding LTS to the name of a release does not make it of higher quality than any other release. What creates the quality is the amount of testing it has undergone. LTS releases are used by much greater numbers of users than development releases so once they are live they are much more thoroughly tested. As 16.04 LTS has been live for less than a month it will have far more bugs than say 14.04 LTS. On Windows my policy was never to use an operating system release until it had been live for at least a year so other people found the bugs. In your case you need a recent kernel to solve another issue so you want to stick with 16.04.

Step 5. Looking at the bug list for GNOME network manager it is clear that they are actively working on a significant number of bugs. It is going to take some time for them to address all the serious ones. Consider replacing the GNOME network manager with another one. Wicd does not appear to be being actively developed but network management standards have been stable for years. I would recommend trying this as it does not depend on GNOME and is unlikely to have the same issue. You have tried Wicd in the past and have issues with it so you would like an alternative approach.

Step 6. You don't actually need a network manager to get Wi-Fi connectivity. You can use a terminal. Detailed instructions are here. Connecting to WPA Wi-Fi from the terminal

  • ubuntu-bug network-manager would probably be a more useful command for reporting a new bug - since it would file logs related to the package and would probably get people who know the program onto the issue quicker – Ads20000 May 20 '16 at 19:47
  • @Ads20000 I agree and I have edited the answer. Thanks. – Steve Roome May 20 '16 at 19:54
up vote 0 down vote accepted

I wanted to report that I never fixed this issue on the particular install of 16.04 that I was running. Luckily, I had 16.04 installed on another computer and used systemback to make a copy and install it on a test partition. The wifi just "worked" under that new install, so I have to infer that there was some conflict or error in my prior install. I appreciate all the help.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.