I recently updated my Lenovo Y50 computer to 16.04. Since the update, I have been unable to see or connect to any wireless networks. The output of running sudo lshw -C network is:

*-network UNCLAIMED
description: Network controller product: BCM4352 802.11ac Wireless Network Adapter vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:08:00.0 version: 03 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress cap_list configuration: latency=0 resources: memory:d1600000-d1607fff memory:d1400000-d15fffff

The fact that the wireless network controller is unclaimed leads me to believe that this is a driver related issue. I have checked and made sure that "Use proprietary driver" is checked in System Settings > Software & Updates > Additional Drivers and I have run sudo apt-get install --reinstall bcmwl-kernel-source I have also restarted after every driver change to finish the changes. Is there anything else I should try?

EDIT: Here is the result of running lspci -nnk | grep 0280 -A2:

08:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
    Subsystem: Lenovo BCM4352 802.11ac Wireless Network Adapter [17aa:0623]
    Kernel modules: bcma, wl

Running sudo modprobe wl && dmesg | grep wl returns an error:

modprobe: ERROR: could not insert 'wl': Required key not available

  • Please edit your question to add the result of these terminal commands: lspci -nnk | grep 0280 -A2 and also: sudo modprobe wl && dmesg | grep wl Welcome to askubuntu.
    – chili555
    May 10, 2016 at 22:37
  • Thank you for your response and thanks, glad to be here. I have made the requested edits to the original post.
    – doolitau
    May 10, 2016 at 23:26

2 Answers 2


modprobe: ERROR: could not insert 'wl': Required key not available

This is the subject of a recent and still open bug in Ubuntu: https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1572659 Please also see: Can't view Wifi networks after upgrading to Ubuntu 16.04

It appears that the only solution so far is to enter the computer's BIOS and turn off Secure Boot.

Secure Boot is a security standard developed by the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer

1) Turn off the secure boot

2) Remove bcmwl-kernel-source

sudo apt-get purge bcmwl-kernel-source

3) Re-install bcmwl-kernel-source .

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

Reboot. Your wireless should now be working.

  • 2
    Bingo! All I had to do was disable secure boot and it worked. Thank you so much, chili!
    – doolitau
    May 11, 2016 at 23:03
  • Excellent that was my solution to reinstall the package, thanks.
    – jjroman
    Feb 17, 2018 at 0:38
  • Thanks! My wireless network stopped working after having worked for a long time. Re-installing bcmwl-kernel-source fixed it.
    – geronimo
    Sep 1, 2018 at 14:28
  • Thank you, works well. If you doesn't have internet because of this problem and can't download the package, you might download it on another computer (named bcmwl-kernel-sourceXXX.deb), or smartphone here: packages.ubuntu.com/… and transfer it via USB. Then locate the destination folder in your terminal, cd there and run sudo dpkg-i ./bcmwl-kernel-sourceXXX.deb (quite long). Then reboot
    – Oscar
    May 24, 2022 at 9:48

I had a similar case, but not related with Secure Boot. For me

sudo dpkg --configure -a

solved the issue.

  • I assume that the installation of bcmwl-kernel-source was interrupted due to which it remained unconfigured since the command you've mentioned is supposed to configure the packages which were left unconfigured during the installation/upgrade.
    – Kulfy
    Dec 10, 2019 at 20:52
  • Thanks @Kulfy for the explanation!
    – murku
    Jan 2, 2020 at 13:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .