0

I'm running default ubuntu 14.04 in combination with awesome WM 3.5.9. To enable proper suspend when I close my laptop lid I enable xfce4 after login through the following awesome command which makes xfce4-power-manager unresponsive:

awful.util.spawn_with_shell("xfce4-power-manager")

when running "ps -ef | grep xfce4-power-manager" I get the following:

test     2277  2273  0 19:28 ?        00:00:00 xfce4-power-manager
test    11842  2365  0 19:39 pts/0    00:00:00 grep --color=auto xfce4-power-manager

so xfce4-power-manager is running unresponsively. However if I change the awful execute to "--no-daemon" mode, it runs perfectly. But not running this sort of process in daemon mode doesn't seem like the proper sollution. Has anyone experienced this problem as well and knows a solution?

0

Unfortunately running it as daemon didn't succeed. I have solved it (ugly way) by setting the following in awesome WM:

awful.util.spawn_with_shell("xfce4-power-manager --no-daemon")

You can also pass the same command to the "run_once" function.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.