0

I have installed linux (Ubuntu 14.04) and Windows 10 alongside. After dividing one partition into two from Windows side, now linux unable to mount the partitions on booting. It shows following error message.

disk drive for mnt/50FE*** is not ready yet or not present. continue to wait ... 
it is possible to manually un-mount 50FE*** partition.

The problem is that after I edit the partition 50FE***, it is not available anymore.

Now i just want to get rid of this error message.
Any help will be appreciated. Thanks

0

Finally I found the solution,

I have manually edited the FSTAB file (etc/fstab). FSTAB contains all the details regarding the mount-points including auto-mount drivers in the boot-up. so delete the line corresponding to the missing disk

here is my FSTAB file

    # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=09642702-1d8e-41b8-897f-98079b8609e4 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=7554c61b-b8c9-45af-b5df-199670167a04 /home           ext4    defaults        0       2
# swap was on /dev/sda6 during installation
UUID=a54e0244-c77d-4672-9df9-2840924e0c94 none            swap    sw              0       0
/dev/disk/by-uuid/50FEFBC9FEFBA4FE /mnt/50FEFBC9FEFBA4FE auto nosuid,nodev,nofail,x-gvfs-show,x-udisks-auth,x-gvfs-name=Windows%2010 0 0
/dev/disk/by-uuid/3C7404F67404B4A5 /mnt/3C7404F67404B4A5 auto nosuid,nodev,nofail,x-gvfs-show,x-udisks-auth,x-gvfs-name=Data 0 0
/dev/disk/by-uuid/01D1953299EF8656 /mnt/01D1953299EF8656 auto nosuid,nodev,nofail,x-gvfs-show,x-udisks-auth,x-gvfs-name=Windows 0 0

in my case i have deleted

/dev/disk/by-uuid/50FEFBC9FEFBA4FE /mnt/50FEFBC9FEFBA4FE auto nosuid,nodev,nofail,x-gvfs-show,x-udisks-auth,x-gvfs-name=Windows%2010 0 0

hope this will help to someone

Cheers !

| improve this answer | |
  • Oh, OK. You were getting that error because when you re-partition a drive, the new partitions are given new UUIDs. The partition wasn't mounting because it basically didn't exist any more by that name. You can run blkid to find UUIDs of your new partitions. – wjandrea May 21 '16 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.