1

I am using authentication via smb and want all users of the admins group as local administrators.

For this I created the /etc/polkit-1/localauthority.conf.d/60-local.conf file as described in pklocalauthority(8) man page containing

[Configuration]
AdminIdentities=unix-group:sudo;unix-group:admin;unix-group:domain-admins;unix-group:admins

The file /etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf provided by the package policykit-1 contains

[Configuration]
AdminIdentities=unix-group:sudo;unix-group:admin

and seems to work...

I checked that I am inside the group admins and domain-admins but whenever I want to do something requiring higher privileges I am getting asked for the password of the local (non-smb) administrator.

What am I missing here?

0

I have not had a chance to test this theory out but I quote these lines from the manual page:

The file 50-localauthority.conf contains the settings provided by the OS vendor. Users and 3rd party packages can drop configuration files with a priority higher than 60 to change the defaults.

I think all you had to do was change your file name to 61-local.conf and that may have solved your problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.