If I try to launch Nautilus in whatever way (from Unity, Terminal), it doesn't launch. Terminal gives me these outputs:


name@machine:~$ nautilus

(nautilus:4367): GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed

Trasovací/ladící past (SIGTRAP) (core dumped [obraz paměti uložen])

launch with sudo

name@machine:~$ sudo nautilus

(nautilus:4672): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(nautilus:4672): GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed

Trasovací/ladící past (SIGTRAP) (core dumped [obraz paměti uložen])


name@machine:~$ nautilus -c
running nautilus_self_check_file_utilities
running nautilus_self_check_file_operations
running nautilus_self_check_directory

(nautilus:4689): GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed

Trasovací/ladící past (SIGTRAP) (core dumped [obraz paměti uložen])

I tried to reinstall Nautilus (with purge), reboot, remove ~/.config/nautilus, step by step at first and then all at once but nothing worked. I haven't changed any configuration or made any significant changes in Ubuntu system since installation. Yesterday Nautilus worked, today doesn't. Does anybody know how to fix it?

  • 1
    After seeing what you have tried already, this looks like something you can't fix yourself. I suggest you report this as a bug at bugs.launchpad.net. – Jos May 10 '16 at 8:32

The schema org.gnome.nautilus.preferences is defined in the file /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.xml which is in the package nautilus-data. Maybe it got damaged somehow.


sudo apt-get install --reinstall nautilus-data

to install that package again.

  • That file had been missing completely. Solution worked, thank you. I thought it could be caused by some broken or missing file. Are you specialist or do you found out that somehow? Is there a way how to recognize, which package has broken or missing file (at least the missing one, broken files are always difficult to spot)? Why nautilus-data cannot be removed if I purge nautilus and with all its no longer used dependencies (is it used by another gnome-based package)? – aleskva May 10 '16 at 17:26
  • 4
    in my case it still doesn't work. I had to execute sudo nautilus ... – bogdan.rusu Nov 12 '16 at 14:25
  • @bogdan.rusu Same here – Jan M. Dec 23 '16 at 12:06
  • 1
    The correct answer should be @Efi Kaltirimidou – Tai Christian May 23 '19 at 8:00

For me terminating the running nautilus process and restarting it worked.

ps awx | grep nautilus

I found the process id and then terminated it with

sudo kill -TERM <id>
  • 1
    That is what sometimes happens on my Ubuntu GNOME 16.04 and your solution is exactly what I've needed. – hata Oct 30 '17 at 14:30
  • 8
    Or you can kill it from process monitor. – Vicky Dec 9 '17 at 14:53
  • wow.. this piece of code helped me. Thanks – MagePsycho Jan 23 '18 at 11:43
  • 3
    Commands didn't help me (or maybe I used the wrong ID), but killing nautilus from the system monitor did it for me. Thanks! – Nat Naydenova Mar 25 '18 at 19:29
  • Still works on Ubuntu 20.04 – Crazy Goblin Nov 20 '20 at 4:40

killall nautilus

will kill all instances.

  • 1
    By far the simplest solution. Should be the top answer. – wordsforthewise Mar 13 at 4:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.