0

I just upgraded from 15.10 to 16.04 on my laptop and now I have errors with IcedTea and OpenJDK-8 related packages. There seems to be a problem with dependencies. Can someone tell me how to get rid of these errors? I have had no success so far.

Here is the output of sudo apt-get upgrade (sorry my system is in French but I think it is straightforward to understand):

[sudo] Mot de passe de brice : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
4 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Paramétrage de openjdk-8-jre-headless:amd64 (8u91-b14-0ubuntu4~16.04.1) ...
update-alternatives: erreur: le chemin alternatif /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/rmid n'existe pas
dpkg: erreur de traitement du paquet openjdk-8-jre-headless:amd64 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg: des problèmes de dépendances empêchent la configuration de openjdk-8-jre:amd64 :
 openjdk-8-jre:amd64 dépend de openjdk-8-jre-headless (= 8u91-b14-0ubuntu4~16.04.1) ; cependant :
 Le paquet openjdk-8-jre-headless:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet openjdk-8-jre:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de icedtea-netx:amd64 :
 icedtea-netx:amd64 dépend de openjdk-8-jre ; cependant :
 Le paquet openjdk-8-jre:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet icedtea-netx:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de icedtea-8-plugin:amd64 :
 icedtea-8-plugin:amd64 dépend de openjdk-8-jre ; cependant :
 Le paquet openjdk-8-jre:amd64 n'est pas encore configuré.
 icedtea-8-plugin:amd64 dépend de icedtea-netx (= 1.6.2-3ubuntAucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                  Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                  u1) ; cependant :
 Le paquet icedtea-netx:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet icedtea-8-plugin:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 openjdk-8-jre-headless:amd64
 openjdk-8-jre:amd64
 icedtea-netx:amd64
 icedtea-8-plugin:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
0

Problem solved! Thank you user xubu1957 on forum.ubuntu-fr.org: cf here

In short:

sudo apt-get purge openjdk-\*
sudo apt-get install openjdk-9-jre icedtea-8-plugin 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.