1

I got the following error while using the sudo apt-get update command.

:~$sudo apt-get update
/etc/sudoers.d/90-cloudimg-ubuntu: syntax error near line 1 <<<
sudo: parse error in /etc/sudoers.d/90-cloudimg-ubuntu near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

See here for the secreenshot

I tried finding a solution, but I want a specific and precised answer. I am new to Ubuntu (14.04), please help me!

0

Type in terminal

pkexec visudo

Change last line

#includedir /etc/sudoers

To

#includedir /etc/sudoers.d

It should work.!

| improve this answer | |
  • Thanks, but Its already "#includedir /etc/sudoers.d" @Harshil – Prabal Rastogi May 10 '16 at 11:14
0

Hold Shift immediately while booting it will open GRUB screen.Now select option recovery mode. Choose to open root terminal. Run mount -n -o remount,rw / and then visudo.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.