0

i have looked at some of the solutions here, but nothing worked: Unable to find expected entry 'main/binary-i386/Packages - Chrome and No more updates for Google Chrome | apt-get update error.

i'm currently running Chrome 45.0.2454 (64-bit) on my Ubuntu 14.04 64-bit box.

I have been trying to upgrade chrom to version 50 for several hours, but nothing seems to work.Tried doing it using Software Centre as well but to no avail (nothing happens when I click "Install" as mentioned in the first answer here as well). When i try to upgrade Chrome to 50, using sudo apt-get update i get,

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file).

i have added [arch=amd64] into /etc/apt/sources.list.d/google-chrome.list, but when i do sudo apt-get update i get the same error message.

my google-chrome.list file looks as below now:

cat /etc/apt/sources.list.d/google-chrome.list

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

How do i upgrade my chrome 45 to 50?

few more information to help someone help me:

sudo apt-get install google-chrome-stable

Reading package lists... Done
Building dependency tree       
Reading state information... Done
google-chrome-stable is already the newest version.
The following packages were automatically installed and are no longer required:
  libkactivities-models1 mysql-server-core-5.5
Use 'apt-get autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 51 not to upgrade.
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: You may want to run apt-get update to correct these problems
  • Is this a 32 vs 64 bit issue? Apt tries to fetch 'main/binary-i386/Packages' which sounds like 32 instead of 64bit – dufte May 9 '16 at 9:55
  • my current chrome version is 64 bit and my machine is 64 bit. does that make sense? – samsamara May 9 '16 at 9:58
0

One possible workaround is downloading and installing latest chrome (.deb) from Google manually.

After having downloading it you have to either installing it by doubleclicking the .deb file or executing

sudo dpkg -i /path/to/local/chrome.deb

Manually installing the deb should as well add a new entry to your sources for later upgrades.

0

My chrome said that google will not support anymore old kernels with updates Maybe thats why it doesn't work! Try to get the latest kernel version and than try again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.