12

I'm using VLC - 2.2.2 on Ubuntu 16.04. VLC is able to play the videos but I'm unable to take the snapshots using it. I tried disabling "Use Hardware Acceleration" by going in Preferences->Video and changing the output to OpenGL (GLX), OpenGL 2 and XVideo,one by one, the later resulted in a black screen.

When I try to capture a snapshot I get this error:

[00007f9440d10248] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  361.42  Tue Mar 22 17:29:16 PDT 2016 for hardware decoding.
[00007f946c509148] vdpau_chroma filter error: corrupt VDPAU video surface 0x7f94208e4950
[00007f94300fca08] core video output error: Failed to convert image for snapshot

Is there a way to tell VLC not to use Hardware Acceleration? My intention is to remain with Hardware Acceleration disabled for now.

17

Answering myself.

The option at Preferences->Video->Use Hardware Acceleration controls how graphics are drawn on screen, not how videos are decoded. The option to disable VDPAU is at Preferences->Input & Codecs. Then look for "Hardware accelerated decoding" and change VDPAU for any of the other options, I'm using X11 VA-API.

And problem solved. I can take snapshots again. I will remain with Hardware decoding disabled until the problem is fixed, probably at the side of the VDPAU driver library (just guessing). No perceptible lag while playing videos so far.

  • 2
    Thanks! I think you can still pick your own answer as the resolving answer too. – Mathieu M-Gosselin Oct 24 '16 at 17:18
  • 2
    I know, I decided to wait for other answers and then forget about this one. OK, accepting my own answer. – Hatoru Hansou Oct 26 '16 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.