Very recently I have made up my mind to use Ubuntu. Firstly installed the 14.10 version and that didn't go well. On that particular version the wireless network option was not visible. I couldn't turn on the wireless connections. After that I re-installed the 16.04 version, in which the option is showing that wireless network is there but no network is showing up. Any suggestion how to solve this problem?


This helped solve the problem for me.

sudo systemctl restart network-manager


sudo service network-manager restart

I am still looking for a permanent solution, but this solves the issue till restart.


Suffered from similar symptoms again. I had a stable 16.04 running smoothly for months and then suddenly yesterday the WiFi just stopped working. No networks would show on the nm applet. Tried quite a few suggestions (including my own) and none worked.

Finally realized that my last upgrade didn't go too well and had crashed in between. Removed the dkpg locks and ran sudo apt-get upgrade. A reboot later, all was back to normal.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock

Ubuntu network manager seems quite fragile!

| improve this answer | |
  • 2
    Any updates on the research for the permanent solution? – SparKot Sep 7 '16 at 5:18
  • this worked for me too. Do you know any permanent solution? – mustafa Jun 2 '17 at 21:13
  • 1
    But I can't run an apt upgrade without Internet... – Aaron Franke Jul 17 '18 at 3:57
  • Add a line greeter-setup-script=service network-manager restart into the file /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf to restart network-manager every time before you enter the greeter. – allenyllee May 1 at 8:35
  • Go to Terminal and type lspci
  • Find the name of your wireless adapter eg: Network controller: Intel Corporation wireless ....
  • Go to System settings > Software and Updates > Additional Drivers
  • If you see name of your Wireless Adapter. Check the adapter is enabled on not. If it is not enabled, click on Using XXYY your adapter name
  • Click on Apply Changes
  • This will install device drivers from manufacturer if available. Once installation is complete you will be asked to restart.
| improve this answer | |
  • this helped me lot saving time. – Tarun Nov 22 '17 at 18:35
  • this worked for me – Surendra Shrestha Jan 11 '18 at 17:22
  • 3
    What if you don't see the name of your Wireless Adapter on the list of Additional Drivers? – BourbonCreams Mar 15 '18 at 15:17

Install rfkill

sudo apt-get install rfkill

then run this command

rfkill unblock all

check if the wifi is working. If not do this

sudo nano /var/lib/NetworkManager/NetworkManager.state

then you will see some settings. Set everything to "true" reboot your system

give this command in terminal

rfkill list

you'll see that some are softblocked and hardblocked. All of them should be "no".

If it's not "no" then you need to somehow turn them to "no". I did this and it worked for me

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

then save the file by pressing Ctrl+O ,close it and reboot the system. It should work

| improve this answer | |

Go to system setting->Network . where you find all the wireless or wifi avaiable there.

| improve this answer | |
  • 1
    system>software and settings>additional drivers check if any wireless drivers are listed for your laptop. – Arup Roy Chowdhury May 21 '16 at 3:40
  • 2
    i have same problem on my lenovo . use this command :-sudo systemctl restart network-manager.service fix my issue. – user546820 May 21 '16 at 3:50
  • When I go to All Settings->Network->Wireless it says airplane mode is on and wireless is off all my networks report being out of range. I can turn airplane mode off but it does not let me turn wireless on. – zorkerz Sep 25 '16 at 22:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.