1

In the pro file I have the following line.

QT += core gui quick widgets quickwidgets declarative sql

When running qmake I get the following error.

error: Unknown module(s) in QT: declarative

I have installed the qtdeclarative5-dev package but when running qmake in QtCreator I still get the above message

Which one do I need install to get the declarative module?

1

Qt 5.0 is compatible only with Qt Creatoe 2.6.1+, so install Qt Creator 2.6.1

Before you start installation lets remove existing version of Qt Creator. Run following command in terminal

sudo apt-get autoremove qtcreator

download appropriate installer from here

go to the directory containing installer and run

chmod 755 qt-creator-linux-*-opensource-2.6.1.bin

Run the installer

sudo ./qt-creator-linux-*-opensource-2.6.1.bin

That's it. if everything goes fine you will be able to use Qt 5.0 with Qt Creator.

Hope this Helps

| improve this answer | |
  • I am using QtCreator 3.5.1, so its fine for the Qt5.5.1 I have on ubuntu. The problem is still there, I need the declarative module on my system, and don't know what package to install. The line in the pro file is the following. QT += core gui quick widgets quickwidgets declarative sql qmake have a problem finding the declarative module. – user58056 May 14 '16 at 16:46
1

After searching allot I found this article. http://doc.qt.io/qt-5/qtquick-porting-qt5.html#qtdeclarative-module-in-qt-5 I had to install the following packages in ubuntu 16.04 to get all the correct modules.

sudo apt-get install qtquick1-5-dev qtscript5-dev

That sorted the problem out.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.