5

This question already has an answer here:

I'm just switched back to Ubuntu, from Windows. I had a program in Windows (Fiddler) which captured all outgoing traffic and could edit their header to use proxy.

Are there any way to force all of my outgoing traffic to use proxy?

If I have edited

/etc/apt/apt.conf 

it does not work.

Someone proposed to use the system proxy settings. That panel edits this file, but not even capable to use the proxy authentication.

Most of my program uses the proxy, but not all.

I tried also to run it from terminal and before running it I set up this:

tpeti@TLabs-MSI:~$ export http_porxy="http://username:password@ip:port"
tpeti@TLabs-MSI:~$ export https_porxy="https://username:password@ip:port"

But this didn't worked also.

Are there any way to force all programs to use proxy, or edit all the outgoing traffic headers to go through the proxy?

And can I do it, with just specific programs too?

Thanks for your help!

marked as duplicate by amc, WinEunuuchs2Unix, karel, Eric Carvalho, David Foerster Nov 4 '16 at 10:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

You need to specify this proxies and apply them system wide. Just collect the IP and Ports for your HTTP and HTTPS proxies and do this with the system proxy setting GUI. Search for Network Proxy in dash.

Try user_name:password@Proxy_IP for the authentication. This seems to be the way to configure it in the configuration file. source

Ubuntu Main

Search the dash Initial view Proxy settings Input proxies here user:password@ip

Mate IN mate there's a checkbox for this if you click on details System-> Preferences-> Internet and Network-> Network Proxy enter image description here

  • 1
    Sorry but that not works. First, the Ubuntu 16.04 config panel don't look like that. The second I told u that to set up the /etc/apt/apt.conf file doesent work. The config panel what you proposed edit the same file, but not even can use the authentication. So thanks 4 the help, but what u propose dosen't work. – TLabs May 8 '16 at 17:59
  • It's the same options as I used in 15.10, maybe there where changes in 16.04 I'll check out the auth detail. – userDepth May 8 '16 at 19:02
  • Mmm yes sorry, that's how FF settings look – userDepth May 8 '16 at 19:03
  • 2
    Your solution with the unity networking isn't working (It saves the whole line as if it would be the IP of the proxy). But with mate the system switches on the defeault authentication. BUT DONT FORCE IT ON ALL THE PROGRAMS :( So it doesen't solve my problem, because more of my programs doesn't use authentication. We checked it on the proxy logs, they not even tried to use the proxy ) – TLabs May 13 '16 at 12:23
  • 1
    @djb askubuntu.com/questions/150210/… – userDepth Aug 11 '16 at 17:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.