1

I want to change my operating system back to Ubuntu after using Elementary OS for a time. I am currently using it on a USB drive to test it.

I tried to install some programs that I have come to enjoy on Elementary like Nylas N1 for email and Clementine for music to make sure that I could transfer all of my data.

The Gnome software centre did not have Clementine as a searchable package.

I tried to get it manually from the site and then install it, which also did not work through either the software center or trying to use the dpkg command in terminal.

I decided to try and get a different package manager. I tried using the command-line to install the old Ubuntu software center, and got an error

E:Package 'software-center' has no installation candidate

as shown in image below.

software center failure

I got the same error when I tried to install the synaptic package manager. It gives me the error

E: Package 'synaptic' has no installation candidate

as shown in image below

error 2 I also tried to compile the source for both programs, but could not figure out how to get them running off the source code.

I found the .deb for the synaptic package manager but I was not able to install that either.

Is there any way to get a different package manager on Ubuntu 16.04 LTS?
Thank you.

Note: I am not new to linux, but am not very familiar with the particulars of the command-line or the syntax that goes along with it.

  • what error are you getting when you try to install synaptic .. I have dealt with 3 different Ubuntu 16.04 flavors and they all were able to install synaptic .. you may be having other issues that are preventing you from installing any software at all – John Orion May 8 '16 at 4:47
  • I think you can install Clementine by "sudo apt install clementine"; I can find it by "apt search Clementine" – alfred May 8 '16 at 4:49
  • John, I am getting the same error that I got for software center, which is detailed in the picture above. – MFab5 May 9 '16 at 1:49
  • @alfred, it did a sort, finished, did a full text search, finished, and then the process ended – MFab5 May 9 '16 at 1:51
  • @JohnOrion I just figured out how to mention you, I responded above – MFab5 May 9 '16 at 2:19
3

Ok, from the description and your added info, I think it is because you are trying Ubuntu(live USB), so not all software repos are enabled. By default, live session only select main and restricted software as below pic: enter image description here

The software you wanted - clementine or synaptic are both in "Community-maintained free and open-source software".

So you can enter in Dash - "software" then choose "software & updates"; or a command line way in Gnome Terminal - run "software-properties-gtk";

Then tick the checkbox before "Community-maintained free and open-source software (universe)"; then close this dialog, let it update software list; Then you can use "sudo apt install clementine" to install clementine and use "sudo apt install synaptic" to install synaptic.

Or by commands:

$ sudo apt-add-repository universe
$ sudo apt update
  • I just did that and it solved the problem, thanks so much – MFab5 May 10 '16 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.