This question already has an answer here:

The brightness function keys on my Asus laptop don't work on Ubuntu. The function key combinations for sound volume (Fn+F12/F11/F10) and turning the screen on and off (Fn+F7), but not those that should adjust the brightness (Fn+F6/F5)...

After some, I tried this itsfoss.com article, but it still doesn't work.

I tried Brightness fn key shortcut doesn't work on ASUS laptop but again no success.

What else can I try?

marked as duplicate by Zanna, Eliah Kagan, Eric Carvalho, karel, Fabby Nov 24 '17 at 7:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Actually, you should post the solution in the answer section. You're not prohibited from that – Sergiy Kolodyazhnyy May 8 '16 at 2:42
  • 2
    Even though that question is mentioned here as not having worked, the OP's own solution is very similar to the solution given in that answer. The question itself seems to be the same and the OP's problem is solved here; the answers are slightly different, and we could perhaps merge after closing. – Eliah Kagan Nov 22 '17 at 10:48

OP's answer removed from the question and edited slightly:

I found the solution on this webpage (in French).

It tells us to

sudo -H gedit /etc/default/grub

then find this line


and add a parameters acpi_osi= and acpi_backlight=intel, so the edited line reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi= acpi_backlight=intel"

save the file, and then to make changes effective, run

sudo update-grub

finally you turn off / restart your monster and it should work!!*

I should mention that I still have the /usr/share/X11/xorg.conf.d/20-intel.conf file as described in the first article I linked to in my question.**

* CW post author's note: You may want to try the boot parameters individually first, rather than together. acpi_backlight=intel should be tried alone first as it has less wide-ranging effects. Don't forget to run sudo update-grub after each change made to /etc/default/grub and then reboot to see if it has been effective.

** CW post author's note 2: my own experience (and the fact that it didn't work for OP earlier) strongly indicates that this file did not do anything good. If you are following this answer, I recommend you do not try to create this file in combination with the edit to /etc/default/grub, unless that method did not work, and the 20-intel.conf solution did not work when tried separately.

Not the answer you're looking for? Browse other questions tagged or ask your own question.