251

I've made an USB installer stick from Windows with Ubuntu 16.04 LTS , now I'm trying to format it from Ubuntu. When I try to format I get this error :

This partition cannot be modified because it contains a partition table; >please reinitialize layout of the whole device. (udisks-error-quark, 11)

2
  • 1
    I had this problem because I had the physical read-only tab set on the sd card. Sep 19, 2019 at 19:16
  • 1
    I know it's too late but I will add the solution anyway. You can follow the instructions here, it works for me and very easy: itsfoss.com/cant-format-usb-disk
    – Elbassel
    Apr 7, 2020 at 10:30

10 Answers 10

512

I got this fixed by doing the following

  1. On your unity dash, type gnome-disks and launch the Disks application

  2. Select the disk or drive you want to format

  3. Press CTRL+F

  4. Click format.

After formatting, the disk or drive would be unallocated, therefore you'll have to create a partition by using the plus button on the screen. Then insert the name you'll like to use as the drive or disk name then click on create.

11
  • 37
    this should be the accepted answer. everything else is too complicated. Jul 1, 2017 at 10:32
  • 11
    After it i got: "The destination is read-only." run: "sudo killall nautilus" to solve it Jan 15, 2018 at 11:56
  • 6
    I did this now, suddenly, my laptop is not reading the USB drive.
    – Suraj
    Jan 20, 2019 at 16:34
  • 1
    @Suraj I got the same result, but there is a dark triangle right next to the gear icon. It looks like those play buttons on audio and video. Anyway, I hovered over it and it said 'mount this device', so I clicked it (I already knew it was unmounted) and presto! we are back in business. Hope this helps you! Mar 2, 2019 at 19:34
  • 4
    "In Ubuntu 19, now it has been changed to CTRL+D to format a drive and CTRL+P to format a partition in a drive." comment on a related thread: askubuntu.com/questions/283545/…
    – noname
    Jul 6, 2020 at 13:41
75

Make sure you have GParted installed. In a terminal window, run

sudo apt install gparted

Then open GParted as root (still in the terminal window):

sudo gparted

Select your USB stick from the GParted > Devices dropdown menu. Then click the "Device" tab > Create Partition Table...

This will erase all the data from the stick, so be sure you don't have anything valuable in it.

There will be an unallocated space left, double click it to create a new partition with your settings, such as disk label and filesystem (you'll probably want it to be NTFS).

Don't forget to apply your configuration by clicking the green "check" button in GParted.

1
  • Thanks, that worked
    – Heisenberg
    Nov 22, 2020 at 17:47
30

You can use the terminal:

1. Find device ID:

df -h

2. Now unmount the device:

sudo umount /dev/sdb1

(change sdb1 with your device id)

3.Format USB

Choose a file system:

Ext4

sudo mkfs.ext4 /dev/sdb1

Fat

sudo mkfs.vfat /dev/sdb1

Ntfs

sudo mkfs.ntfs /dev/sdb1
3
  • 1
    This won't help because it appears there is no partition table and hence no partitions to format on the device in question in the first place. May 3, 2017 at 10:47
  • You're missing the point: there are no partitions to format according to the question. Your explanation how to format partition is correct but not helpful here. May 19, 2017 at 20:11
  • I was trying to format a usb stick which I was using for to install ubuntu, it was bootable. When I check the disk partitions, there were 3 parts and I was trying to format one by one like sudo mkfs.vfat /dev/sdb1 but it didn't work for me. I tried without one by one like, First I unmounted with sudo umount /dev/sdb and I formatted with sudo mkfs.vfat /dev/sdb I hope it might work for you.
    – Ermanas
    Apr 22, 2021 at 11:24
5

If the standard tools cannot restore the USB installer stick alias pendrive to a standard storage device, you can use mkusb-dus, which has a menu option to do it automatically,

  • wipe the first megabyte and restore the drive to a standard storage device (with the MSDOS partition table and a partition with the FAT32 file system).

See these links

There is a more general description of what to do, if you have problems with a USB pendrive in the following link,

enter image description here

enter image description here

2
  • 1
    This is the Best answer. OP can do what he needs easily. Apr 4, 2017 at 4:51
  • dus is awesome and easy to use! I love this
    – wadie
    Apr 26, 2017 at 18:24
4

Check disk by issuing below command

sudo fdisk -l

You can find the usb disk, usually it would be /dev/sdb or /dev/sdc. Check if any of the partitions of the disk is not being used.

sudo df -h

If you find any of the disk partitions like /dev/sdb1 or /dev/sdc1 then you need to unmount it first:

sudo umount /dev/sdb1

Now format the USB stick with desired file system like fat (general), ext4 (Linux) or ntfs (Windows):

sudo mkfs.ext4 /dev/sdb
sudo mkfs.fat /dev/sdb
3

the @Eduardo Cola is solving the problem but after it I got:

The destination is read-only.

that was solved by:

sudo killall nautilus
2

I ran into this issue as well. I was able to get around it using sgdisk.

sudo sgdisk --zap-all /dev/sdd

1

I got the same error when I mistakenly selected Format Partition option (using the gear icon near the + sign). Then I found that the Format Disk option, which I needed to format the USB disk(!), was located (/hidden) under the (3 dots) menu, in the top right corner of the Disks (gnome-disks) window.

enter image description here

0

If you use a desktop version then the easiest way will be to go to the Disks tool.

  • select your usb drive
  • delete Ubuntu 16.04 Partition 2 clicking on minus (next to start/stop and config options)

    Try to format the usb now. If the error still exists, just plug it off and on again. Now you can format it without errors.

0
0

This happens to me every time I format my Ubuntu live USB back to FAT.

The solution worked for me:

Identify the device:

sudo fdisk -l

Re-write the device blocks:

sudo dd if=/dev/zero of=/dev/sdX bs=2048 count=32

Modify sdX with the appropriate device name.

Then run

gnome-disks

to format the USB flash.

Not the answer you're looking for? Browse other questions tagged or ask your own question.