2

I have a couple of Jetson TK1s and Jetson TX1s running Ubuntu 14.04 (Linux4Tegra). I need to be able to switch between two network configurations - an "office" one where I'm in the office and can access the company network (DHCP), and a "field" one where the the network interface is static. To do this I have two network interfaces files:

/etc/network/interfaces_office:

auto lo
    iface lo inet loopback

auto eth0
    iface eth0 inet dhcp

#allow-hotplug eth0
#   iface eth0 inet dhcp

/etc/network/interfaces_field:

auto lo
    iface lo inet loopback

auto eth0
    iface eth0 inet static
    address 10.20.3.137
    netmask 255.0.0.0

My /etc/network/interfaces file is then just a symlink that I can easily change to point to which file I'd like to use. This setup works fantastic on the TK1s that I have.

On my TX1 though, whenever I do this, eth0 doesn't come up automatically on startup. I've disabled network manager (by creating a /etc/init/network-manager.override file that contains "manual") to make sure it's not interfering somehow.

When I connected to the serial port with an FTDI cable to monitor the start up the message RTNETLINK answers: Network is unreachable is displayed repeatedly until I manually start eth0 using sudo ifup eth0 Is there a reason eth0 won't come up automatically?

I would really like to use the allow-hotplug option that's commented out above instead of just auto so that booting the Jetson isn't delayed if the network cable isn't in. I'm also not sure if this is Jetson issue or an Ubuntu issue so this is also posted here.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.