0

Desktop: Gnome/Unity | Distro: Ubuntu 14.04 trusty | Kernel: 4.2.0-35 i686 (32 bit)

I've never, ever, ever had problems with this faithful old laptop, until installing 14.04. Can't get trackpad to work. USB mouse functions. Initially, the mouse cursor didn't have appear. Solutions I've tried, but which haven't worked:

1.) Reverting to older Kernel.

Touchpad/Trackpad is not found by Ubuntu 12.10 but external USB mouse works

2.) Reloading the mouse driver didn't work:

sudo modprobe -r psmouse sudo modprobe psmouse proto=imps

Synaptic touchpad on laptop not working

&

http://ubuntuforums.org/showthread.php?t=1971196

3.) I have tried:

sudo apt-get install xserver-xorg-input-synaptics

But am greeted with dependency hell: Depends xorg-input-abi-20 & Depends: xserver-xorg-core (>= 2:1.14.99.902)

Trying to resolve these dependencies takes me down the rabbit hole. What's going on here? Why is this package in the repositories if it's pre-broken?

4.) Tried all the solutions here:

Ubuntu 14.04 no cursor after fresh instalation

Including:

dconf reset -f /org/compiz/ setsid unity unity --reset-icons

And:

Open System Settings > Displays. Disabling "Unknown Monitor" but there was no unknown monitor to disable.

And:

sudo service lightdm restart

5.) And:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

From here:

How to restart only missing/invisible mouse pointer/cursor?

So, would love some of that LTS support from Ubuntu right about now. :)

1

I discovered that my daughter had accidentally turned off the touchpad! A nice little feature, a discrete little button, on this old laptop that's persistent from one session to the next.

So... there's one solution. Kind of like plugging in ones computer... :-/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.