2

I just bought a Dell Inspiron Mini 10 with a Realtek HD ALC269 sound card and whatever sound it produces, it's broken. If I can't fix it, will have to put it back into WinXP and my little son will get used to M$ products!!!

Please help!!!

Some extra info: http://www.alsa-project.org/db/?f=5babb67a654bb45c8cd1721ec716ed38f9f840c1

Update: This is how "Again" from Lenny Kravitz sounds: https://clyp.it/cwrslpt2

  • What do you mean by broken? Even a little bit of details would be useful next to none. PS: Given the lack of support for Intel's GMA500, that Dell mini 10 was not the best choice. – mikewhatever May 7 '16 at 13:13
  • I know now :/ Sound comes out distorted, like if it was jumping from one place to the other. Initially I thought that it was skipping because of the under powered atom CPU, but did an htop and it tops at 45% during playback. – rreyes1979 May 7 '16 at 13:35
  • Not sure what that means, but I'd try [these workarounds](|wiki.ubuntu.com/Audio/PositionReporting). – mikewhatever May 7 '16 at 13:54
  • @mikewhatever: Updated the post with an example of how it sounds right now. Tried your workarounds, executing 'sudo alsa force-reload' on each change to alsa-base.conf, but nothing yet. – rreyes1979 May 7 '16 at 14:14
1
  1. Close any open audio programs.
  2. Stop the daemon from respawning:

sudo nano /etc/pulse/client.conf

Uncomment the line that reads:

; autospawn = yes

to say:

autospawn = no

Then press CTRL+X to save these changes.

  1. Stop the existing PulseAudio daemon from running:

pulseaudio --kill

  1. Now try playing an audio file from a media player of your choice. This will play directly to the hardware, but will mean only one program can play sound at a time.

To revert: Comment the line again (with a ;), and type pulseaudio into the terminal to start the daemon again.

Source: https://ubuntu-mate.community/t/choppy-sound-dell-mini-10/2401/3

UPDATE: If you want to keep pulseaudio active, edit /etc/pulse/default.pa, find the following line:

load-module module-udev-detect 

and append "tsched=0" to the end:

load-module module-udev-detect tsched=0

restart pulse (or just reboot your system), and the crackling should be gone.

Source: https://askubuntu.com/a/201747/52568

0

The HDA audio chips need sometimes a manual intervention to make them work correctly. Try the following and see if it corrects your issues:

sudo modprobe -r snd_hda_intel
sudo modprobe snd_hda_intel model=dell

repeat both steps with model=lifebook and model=laptop-amic instead of model=dell if the first step was not successful.

If you are happy with one of the options, you should make it permanent.

With sudo, edit the file /etc/modprobe.d/alsa-base.conf and add the line

options snd-hda-intel model=XXX

with XXX being the option you identified above.

I have seen one report of getting problem-free audio after apt purge pulseaudio, but this seems a bit drastic for me. But you can try if nothing else works - the machine works fine with ALSA alone, and on a system like this, you won't benefit from pulseaudio's features anyway.

  • 1
    Tried 'sudo modprobe -r snd_hda_intel' but I am getting the following error: modprobe: FATAL: Module snd_hda_intel is in use. Tried with '-rf' but still the same. – rreyes1979 May 7 '16 at 14:26
  • What does lsmod | grep snd_hda_intel show? If the module relies on other modules, these need to be removed first. – emk2203 May 7 '16 at 14:29
  • This is what it shows: pastebin.com/sZsnCaNG – rreyes1979 May 7 '16 at 14:41
  • Tried the second command with the different models but no luck yet :/ – rreyes1979 May 7 '16 at 14:42
  • If you use the second command, you need to restart if you can't remove the module. It's more tedious, but works as well. You could cycle through the options by changing the .conf file and restarting after each change. – emk2203 May 7 '16 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.