5

The software updater displayed a message that new update are available. I chose install update. Apparently, the updates were supposed to install Kernel version 4.4.0-22. But, the installation process got stuck midway for several hours. I interrupted the update process and ran the command "sudo dpkg --configure -a". The same thing happens here, too. It gets stuck at "run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-22-generic /boot/vmlinuz-4.4.0-22-generic"

The results of the command:

    sudo dpkg --configure -a
    Setting up linux-image-4.4.0-22-generic (4.4.0-22.39) ...
    Running depmod.
    update-initramfs: deferring update (hook will be called later)
    The link /initrd.img is a dangling linkto /boot/initrd.img-4.4.0-22-generic
    vmlinuz(/boot/vmlinuz-4.4.0-22-generic
    ) points to /boot/vmlinuz-4.4.0-22-generic
    (/boot/vmlinuz-4.4.0-22-generic) -- doing nothing at /var/lib/dpkg/info        
    /linux-image-4.4.0-22-generic.postinst line 491.
    Examining /etc/kernel/postinst.d.
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-22-generic /boot/vmlinuz-4.4.0-22-generic
    run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-22-generic /boot/vmlinuz-4.4.0-22-generic

I would appreciate any help with this.

Update:

I also tried to remove the half-installed kernel packages with the command "sudo dpkg -P linux-generic linux-image-extra-4.4.0-22-generic linux-image-generic linux-image-4.4.0-22-generic". It also gets stuck. Here's the output to the command:

    sudo dpkg -P linux-generic linux-image-extra-4.4.0-22-generic linux-image-generic linux-image-4.4.0-22-generic
    (Reading database ... 288791 files and directories currently installed.)
    Removing linux-generic (4.4.0.22.23) ...
    Removing linux-image-generic (4.4.0.22.23) ...
    Removing linux-image-extra-4.4.0-22-generic (4.4.0-22.39) ...
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-22-generic /boot/vmlinuz-4.4.0-22-generic
    run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-22-generic /boot/vmlinuz-4.4.0-22-generic
2

Apparently, I have found the culprit. I reinstalled Ubuntu. Updated everything including the kernel. No problems up to now. Next, I started installing the applications I needed. The first one was Eset Nod32 Antivirus. After installing it, restarting, and logging in, Ubuntu froze. After booting into the recovery mode (the graphic mode) and unistalling Eset Nod32 Antivirus and restarting again, everything returned to normal. It seems as if there is a clash between the Linux kernel 4.4.0-22 and this antivirus, for some reason.

0

I got the same thing this morning - great way to start the day, right? ;)

After playing around with various suggestions and ideas found via Google, I got frustrated and in my typical fashion started doing things my way. :) I am not sure my fix is the true solution, however it got me through the issues.

In my evaluation of the failed install (easy to replicate, just install or remove ANYTHING), I found the first error in the cascading chain lies in grub2-mkconfig not existing! Lots of stuff on Google for Fedora and SUSE, but not much Ubuntu based. grub-mkconfig exists in /usr/sbin, so I created a symbolic link to get me a grub2-mkconfig based on something besides an empty script. This created an error because there is no grub2 in /boot. Another symbolic link so /boot/grub and /boot/grub2 are the same and everything seems in order.

I see this as a duct tape style patch more than a true fix as I haven't addressed the issue - a missing grub2-mkconfig as it's supposed to exist. A true solution would me more akin to finding and installing a proper grub2-mkconfig. But I'm lazy and short on time, so... maybe after I'm done procrastinating the rest of my to do list. ;)

  • 1
    Being a complete noob, I struggled for several minutes to understand what you are saying. Then I created a link to grub-mkconfig named grub2-mkconfig in /usr/sbin and a link to /boot/grub named grub2 in /boot using nautilus, but it didn't solve the problem. Could you please be more specific what I should do or write some commands I can copy and paste in the terminal? – Caminostro May 7 '16 at 22:16
  • Sorry for the confusion, I've been doing Unix speak since 1984 and it's hard not to get too abstract and bizarre. :) Glad to see you've got it solved (above) though! It always seems to be some obscure little thing you don't expect or overlook doesn't it? – Tim Oates May 8 '16 at 22:47
-1

The 'solution' is to uninstall nod32 before kernel/nvidia update.

It's a bad solution but works - blame eset devs.

I recommend contacting their tech support.

This thread contains the same 'solution'

https://ubuntuforums.org/showthread.php?t=2329082&page=7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.