2

I'm having trouble getting tmux to accept a caps-lock key that has been remapped using setxkbmap. I use the following:

setxkbmap -option ctrl:nocaps

When running tmux, the usual BASH command line editing is fine with this "new" control key (the old caps lock button) -- works for moving cursor forward/backward, previous commands, etc. However, the tmux prefix key combination will not accept this new key, if I try to use the "new" ctrl button while running tmux, I am unable to call the prefix, making tmux unusable.

I am running ubuntu 14.04, gnome-terminal, and tmux version 1.8. I have also tried using the gnome-tweak-tool to change the caps lock to ctrl, and using setxkbmap -option ctrl:swapcaps also.

Neither improves the situation. Oddly, when swapping keys the "new" capslock (old ctrl) is acknowledged by tmux, all of the following text is capitalized.

If this seems like an inappropriate place for this question let me know, I'll place it on tmux github issues. Thanks.

  • Okay, without really knowing the mechanism behind this error, I fixed the problems by resetting the caps lock, then changing it back to ctrl: setxkbmap -option then: setxkbmap -option caps:ctrl_modifier Now tmux likes my setup. – Daniel81 May 8 '16 at 23:21
  • Or not. This solution is not stable. For what ever reason, this correction lasts for an indeterminate amount of time then reverts to my original problem. I'm at a loss. – Daniel81 May 9 '16 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.