1

Is the Gigabyte BXBT-1900 good with Ubuntu 16.04? Any issues with it? I'm currently running 14.04 and want to upgrade if the J1900 can handle it.

1
  • If 14.04 works well on it, chances are 16.04 will work just fine. You can always boot into the 16.04 live DVD/USB to try it out, just to make sure.
    – user533208
    May 6, 2016 at 23:47

1 Answer 1

1

I have had 16.04.1 (64-bit) running smoothly on a BXBT-1900 for a couple of weeks now. BIOS version F8. Initially there were some serious problems: the machine would freeze randomly (requiring a hard reset) after anything from a few minutes to a few hours of usage. I found other reports of the same problem in this thread, and following the advice of one of the posters there I disabled the following BIOS features:

  • Intel Virtualization
  • Intel Speedstep technology
  • Turbo mode
  • Smart connect

Initially I disabled smart fan control too, but found that (1) enabling it doesn't seem to affect stability and (2) disabling it causes the fan to run very noisily at full speed all the time, so it's now enabled again. With these modifications, the machine appears to be entirely stable so far.

Kernel bug 109051 appears to be related to these freezes, but I haven't tried out the workaround suggested in the bug report.

Update: the machine has now been running smoothly for a couple of months and I'm happy with it. In case anyone else is having problems with this model, here's a full dump of all relevant BIOS settings and data:

Project name: GB-BXBT-1900(MZBAYAB-00)
BIOS Version: F8
Build Date and Time: 03/02/2016 18:43:21
Total Memory: 8192 MB (LPDDR3)
TXE FW Version: 01.01.02.1120
CPU SMART FAN Function: Enabled
CPU FAN Fail Detect: Disabled
Wake system from S5: Disabled
Intel Virtualization Technology: Disabled
EIST: Disabled
CPU C state Report: Disabled
SATA Mode: AHCI Mode
SATA Port: KINGSTON SV300 (120.0GB)
CSM Support: Enabled
LAN PXE OpROM: Disabled
DVMT Pre-Allocated: 512M
Onboard Audio: Enabled
Onboard LAN: Enabled
OS Selection: Windows 8.X
ERP Lowest Power State Mode: Disabled
Restore AC Power Loss: Power Off
System Mode: Setup
Secure Boot: Not Active
Secure Boot: Enabled
Secure Boot Mode: Standard
Fast Boot: Disabled
Boot Option #1: P0: KINGSTON SV300S...
Boot Option #2: UEFI: Built-in EFI ...

Of course I don't claim that this is the only configuration that will give a stable system, but having a well-documented "known good" configuration may save other users a lot of trial and error :).

3
  • Why haven't you tried the suggested workarounds? This question will probably be closed to it being a bug unless you can provide data that you situation is different. Aug 31, 2016 at 18:44
  • @KevinBowen I didn't try the kernel option workaround because the BIOS option workaround was effective. I'm afraid I don't really understand your second sentence. Presumably the problem is indeed due to a bug, but I don't see why that would be a reason to close the question.
    – Pont
    Aug 31, 2016 at 19:07
  • I am running Majaro on my j1900, it used to freeze a lot, especially playing video until I downgraded the kernel to 3.16. When Manjaro does an update sometimes it updates thr kernel to the newest version and the problems return. bbs.archlinux.org/viewtopic.php?id=192821 Nov 10, 2017 at 8:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.