7

I've just upgraded to 16.04 LTS and am sorry I did it. 15 had some quirks, but this is off the wall.

It takes forever to boot, systemd-analyze blame reports:

3min 261ms powerd.service
22.414s wicd.service
22.094s click-system-hooks.service
17.258s NetworkManager-wait-online.service
16.820s apport.service
16.813s irqbalance.service
16.544s networking.service
16.279s stunnel4.service
12.719s grub-common.service
12.047s dev-sda1.device
11.933s ondemand.service
11.382s speech-dispatcher.service
9.283s lightdm.service
8.955s apt-daily.service
8.020s apparmor.service
7.109s pulseaudio.service
6.685s winbind.service
6.673s nmbd.service
6.410s samba-ad-dc.service
6.036s user@1000.service
5.834s ModemManager.service
5.182s console-kit-log-system-start.service
5.001s systemd-user-sessions.service

Can someone suggest anything?

  • 1
    I tried to completely remove NetworkManager-wait-online.service from boot chain using sudo systemctl stop NetworkManager-wait-online.service && sudo systemctl disable NetworkManager-wait-online.service, the command executed successfully, however, at next boot NetworkManager-wait-online.service was active and running and therefore responsible for my slow boot again. Is this a bug? – KernelPanic May 14 '16 at 15:52
  • my kernel boot in 18s + 11s user space ... before it was 10s in total. – Postadelmaga Jun 11 '16 at 2:55
  • systemctl mask NetworkManager-wait-online.service – Postadelmaga Jun 11 '16 at 2:57
6

I had partial success today. One of the most helpful diagnostics is:

systemd-analyze plot > <some_file_name>.html

Use a browser to view it. This made it clear that powerd.service was the biggest problem. It never actually got started, and the boot just waited until it timed out. Since powerd.service never really started, I figured I wouldn't miss it if it wasn't there, and, sure enough, I removed the powerd package and now the boot time is just slightly over a minute(vs. 3.5 minutes with it).

I really don't know if powerd is supposed to be running on my computer(a laptop) as it seems all the documentation I can find describes it's use for a phone. Anyone know if this is true?

The next slowest service to start is wicd.service. This actually gets started, but takes about 36 seconds. Not sure why, but that is the next thing I will look at.

4

My /etc/fstab had two swap partitions. I used blkid, identified the working swap. Then used gsku gedit /etc/fstab to edit the file, commenting out the redundant swap. Boot time greatly improved from several minutes to seconds.

  • I had a similar problem after messing around with a DD clone from disk to disk. Was solved after I fixed the partition IDs in /etc/fstab . My swap partition had an ID which was not present on the system. Bootup dropped to < 5s from more than a minute after the /etc/fstab change. – AllBlackt Oct 18 '16 at 18:47
1

In my case all problems are gone after I changed a BIOS option.

The culprit was C1E, which was fixed on enable (listen "always") - with this setting my system was taking 1,2,5 10 minutes to boot.

C1E is speedstep or cool&quiet for your motherboard buses (hyper transport, pcie etc ...) with AMD CHIPSETS.

I set it to AUTO, so that it will be available AND enabled whenever the system (any kernel module) accesses and decides to activate it.

TESTING

To exclude lots of dynamic hardware settings related problems my advice is:

1. - Set BIOS to optimized default - Disable all integrated peripherals, except ata ) (fixed value if possible) - Disable cpu energy saving features (speedstep, cool&quiet, EIST, PowerNow! oc auto tuning options) - Disable C1E support for amd too

2. - All of that with and without "plug and play os" enabled

3. - After that try enabling one by one all integrated devices disabled before

In my case:

  • My system was getting into a loop with the state of buses because their states were inappropriate at module load time
  • AND/OR bus data was always shown and system modules didn't handle it at boot time
  • OR modules wanted the C1E option available, not enabled in newer versions so that it can be activated and properties handled when it is time.

Remember:

C1E Support Enable : Doesn't work C1E Support Disable : Works C1E Support Auto : Works

MY SETUP:

MB Manufacturer: Gigabyte Technology Co., Ltd. Product Name: GA-MA790X-UD3P

PROC
AMD Phenom(tm) II X3 720 Processor

RAM 4x2Go DDR2 800 dual channel (unganged mode)

GC Gigabyte Nvidia 610/1024Mo / 375.26 from graphic drivers ppa

Ethernet Intel pro server 1000 / 82572EI

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.