When I try to run software-center from the terminal it gives me:

Traceback (most recent call last):
  File "/usr/bin/software-center", line 33, in <module>
    from gi.repository import Gtk
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 224, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 523, in <module>
    class FontSelectionDialog(Gtk.FontSelectionDialog, Dialog):
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 105, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'FontSelectionDialog'

A similar response is given when upgrade-manager or the advanced-settings (for Gnome Shell settings) is attempted. These are all the malfunctioning applications I know of right now, but there may be more. I'm running Ubuntu 11.10 and the Gnome-Shell environment. The error occurred after an automatic upgrade (I think). I have found people with the same or similar problem but none of the fixes has worked for me. I have tried reinstalling python2.7 and some of the other packages via Synaptic. I can still upgrade my distribution since I can run Ubuntu Tweak, but I'd like to sort this out. I have been using some of the experimental repositories for Gnome Shell development but since I figured this might be the reason for the error I purged (successfully I hope) and disabled them via Ubuntu Tweak.

Help on a basic knowledge level would be much appreciated.

  • What does apt-cache policy python-gobject print? – Florian Diesch Nov 7 '11 at 18:05
  • It prints: Installed: 3.0.2-1~oneiric1 Candidate: 3.0.2-1~oneiric1 Version table: *** 3.0.2-1~oneiric1 0 100 /var/lib/dpkg/status 3.0.0-0ubuntu4 0 500 se.archive.ubuntu.com/ubuntu oneiric-updates/main i386 Packages 3.0.0-0ubuntu2 0 500 se.archive.ubuntu.com/ubuntu oneiric/main i386 Packages – user32331 Nov 7 '11 at 18:13
  • Alrigthy, so what to do? Surely there must be some way to resolve the problem and proceed with non-developmental upgrades again? – user32331 Nov 7 '11 at 18:28
  • Issue Resolved! I thank you all. Adding back ppa:ricotz/testing and then purging it with ppa-purge solved the problem for me. My Gnome Shell usage will go through the stable channels from now on, at least until I know more about it. Again, thanks. – user32331 Nov 7 '11 at 20:12
  • This question is a duplicate of this one. However, the older question didn't get any answer. – jcollado Nov 14 '11 at 21:14

Install the package ppa-purge activate the PPAs again and use ppa-purge to deactivate them.

If that doesn't work use the "Origin" button in Synaptic to see the list of used package sources. For every package in every non-official package source use Package-> Force Version from the menu and select the most recent version from an official source.


Try this

sudo rm /var/lib/apt/lists/* -vf

sudo apt-get update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.