31

The headphones are detected, because when they are plugged in, they appear in the sound settings.

The problem is that they just don't output any sound.

Laptop speakers output sound just fine.

I'm running Ubuntu 16.04 x64

This is the output from running alsa-info.sh:

http://pastebin.com/1aDcq86B

What steps can I take to try and debug this issue myself?

Edit 1

Thanks to @Rexford and this answer, I've worked out how to get detailed debugging output from pulseaudio, by temporarily modifying /etc/pulse/client.conf using the --log-level flag.

I'll report back after I play around with this new information and try to find the problem.

Edit 2

Woke up this morning planning on getting to the bottom of this issue, when I discovered that the sound from the headphones started working.

Last night I had tried many solutions (from various forums and webpages), but was not restarting my computer (was just doing pulseaudio -k && sudo alsa force-reload).

So I guess that the reboot was necessary to make one of the solutions kick in and actually work.

One of the biggest things I tried was uninstalling pulseaudio, installing gnome-audio as a replacement and going back to pulseaudio. So I recommend others try that if they are struggling. Just note that if you do that, you should follow the instructions here to get your volume/sound icon back (if it's missing after reboot - which it was for me).

I can't get to the root of this problem now, because it no longer exists for me.

Edit 3

The problem came back...

Debug logs from pulseaudio don't reveal anything useful (e.g. error messages).

According to this diagram, alsa is the next stop to check for the cause.

5
  • First, is your headphone working? Try with another device to confirm! Second, is your laptop jack working? Try another headphone to confirm! If headphone and laptop jack is working, then back to software. Thinking of what could go wrong, but check the above and let's see.
    – KhoPhi
    May 6, 2016 at 12:48
  • Headphones work fine in my phone and have also tried another working pair of headphones in the laptop. May 6, 2016 at 13:00
  • 1
    Okay, thanks. Please, have you seen this? askubuntu.com/questions/219342/…
    – KhoPhi
    May 6, 2016 at 13:09
  • I had not. This is what I was looking for (ability to get more detailed debugging information about what is going on with regards to sound), Thank you very much, I'll update my answer. May 6, 2016 at 14:41
  • I have the same issue with 17.10.
    – Mateva
    Mar 12, 2018 at 10:13

2 Answers 2

78

This answer appears to be working for me, but I have not investigated why yet.

To repeat the solution, just run this command in a shell (no root needed):

alsactl restore
14
  • 5
    This works for me too and I don't understand why! Scary!
    – user5245
    Jun 1, 2017 at 2:53
  • 2
    Worked for me as well. I lost the sound on my headphone after I upgraded my linux kernel from 4.4 to 4.12, on my dell xps 13 (9360) running on ubuntu 16.04.
    – edelans
    Aug 8, 2017 at 13:31
  • 2
    Didn't work in my case...
    – Dr_Zaszuś
    Oct 12, 2017 at 15:11
  • 1
    Did not work for me.
    – a coder
    Feb 26, 2018 at 19:31
  • 1
    Still needed/works on Ubuntu 20.04 LTS
    – Josh
    May 12, 2020 at 16:04
0

I had the same problem with Ubuntu 20.04, I fixed the issue by removing and reInstall ALSA and PlusAudio into Ubuntu Like the suggestion from this article.

Here are Linux Commands for Remove and ReInstall:

sudo apt remove --purge alsa-base pulseaudio
sudo apt install alsa-base pulseaudio

Then You can Reload ALSA again(Optional Step) from the same article again:

alsactl restore

Or Using force

sudo alsa force-reload

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .