7

Bluetooth just absolutely refuses to connect to any audio sinks. I've tried with two separate speakers that I can pair with just fine on iOS, yet when I try, I get this error in blueman:

Connection Failed: DBusFailedError: Protocol not available...

It doesn't even show up in pulseaudio (probably because I can't connect).

I've googled and come across tons of "solutions" that never work. I've honestly tried so many, I forget what I've even tried.

This is important to me because I set up Ubuntu for the purpose of having a HTPC, yet it's lacking functionality to connect with Bluetooth speakers. Any help would be greatly appreciated.

2
  • I just want to share my experience with bluetooth problems under Linux Mint 17.2, 17.3 and 18. Problem was my card (Broadcom BCM4352) and bcmwl-kernel-source driver which didn't work very well. I spent hours of trying to get BT running. Wifi also has connection aborts from time to time. So I bought INTEL AC8260 combo card and everything works like a charm. "pactl load-module module-bluetooth-policy" and "pactl load-module module-bluetooth-discover" worked for me now. Thanks!
    – Daniel
    Aug 9 '16 at 16:59
  • 3
    [sic] is usually meant to indicate an error reproduced as-is. But "sink" is the correct term here, not an error. A bluetooth audio "sink" is something that receives bluetooth audio. This is bluetooth standard terminology, and it distinguishes the device that receives bluetooth audio from the device that sends it. Jan 18 '17 at 3:37
7

In my case, this was solved by using these two commands:

pactl load-module module-bluetooth-policy 
pactl load-module module-bluetooth-discover
1
  • Your first command gave me "Failure: Module initialization failed", but the second command made it possible for me to connect to my BT headphones as 'audio sink'; formerly they would only connect as 'headset service', which wasn't any use to me. Feb 18 '18 at 19:49
1

Might want to check you have pulseaudio-module-bluetooth installed. I was having trouble until I found this post on GitHub Not saying this is an answer to this specific problem but just to make sure.

sudo apt-get install pulseaudio-bluetooth
killall pulseaudio 
1
  • command here was: sudo apt install pulseaudio-module-bluetooth
    – nmz787
    Feb 21 '19 at 8:00
0

Try this:

sudo /etc/init.d/bluetooth restart

pulseaudio -k

pulseaudio --start

Then go to the audio manager, and make sure the program that's generating audio has the Bluetooth "sink" as output.

Reference link - https://github.com/blueman-project/blueman/issues/304

1
  • 4
    Doesn't fix it, nor do I see how it would. The problem isn't with PulseAudio, it's with Bluetooth. It says, after I've gone through "Add new device," that it was "Added successfully but failed to connect."
    – tayoung
    May 7 '16 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.